View Full Version : NP3300/12 don't play Radio at all

11-22-2012, 10:07 PM

I received delivery of my NP3300/12 today & tried in vain for more than 5 hours to get it to play!
I can stream music fine from my PC/Upnp server/.... but have no access to any online Services or Internet radio.
This was the reason why I bought this device :(

When I press Internet Radio I get a message saying 'Empty List'

I've checked everything network side, all is working find. Tried to disable my firewall, put the radio on DMZ, always the same.

I have seen incidents like I am facing in this forum earlier and looks like Philips corrected those at their server & then things were fine by entring the MAC ADDR.

here is my MAC ADDR : 188ED537BD9B

please help



Philips - QK
11-23-2012, 12:48 AM
Dear Laurent,

Welcome to the forum here!
We have already sent your case to our backend team to check the connection as per your MAC address. This may take some time. We will update you on this when we hear back from our backend team.

Kind regards,
Philips Moderation Team

11-23-2012, 06:17 AM
hope it won't take a lot of time.
this is a bit frustrting having a radio not able to play radio !!!



11-23-2012, 12:25 PM
Quick update
I've tried the same radio on a network with ip range 192.168.1.x and it works.
my network is with ip range 10.0.0.x !!!
is there something hardcoded in the firmware ?
Can someone from Philipps can confirm or not this is a known "limitation" of this product ?


11-26-2012, 01:35 PM
No, there is no hardcoding.

The device normally gets automatically from the router an IP-address assigned (unless you've switched it off). But, you've indicated that you can stream from the PC, so I would assume that you have a proper IP (actually you could check that in your units display == SETTINGS / DEVICE ID and INFORMATION).

Would assume you've a proper IP, so seems the unit can't go outside your local network.

Maybe you wait for the feedback from Philips.

BTW, do you have any PRODUCT REGISTRATION ID shown in the same menu ? (format XXXX-XXXX-XXXX-XXXX).
(you don't need to write it here)

12-19-2012, 10:16 PM
Hello everyone.

I was having the same problem: "When I press Internet Radio I get a message saying 'Empty List'".

When I completed de registration proccess(open a mail to confirm the registration) it starts working.


01-16-2013, 08:31 PM
Hello everyone,
Sometimes, after i found the np3900 re-booted for some unknown reason, i also found empty list.
I had to force a complete start by pressing the stop button during some seconds, and after, it works again ...
Hope it helps ...