Im also very interested in getting the 1.56 software, cause a lot of new BRs are not recognized by the player anymore since I upgraded to 1.60. mail me please If you can help me out....