Results 1 to 3 of 3
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 55, Level: 1
    Level completed: 5%, Points required for next Level: 95
    Overall activity: 10.0%
    Achievements:
    Tagger Second ClassNew Achievement!

    Join Date
    Jan 2013
    Location
    Eindhoven, The Netherlands
    Posts
    3
    Points
    55
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Subwoofer of *new* HTR-9900 set died after 30 minutes?

    Hello,

    Today I received the HTR-9900 set I ordered.
    Sounds amazing.
    After setting up eveything, I ran the SmartEQ with the microphone to set it up.
    Eveything worked ok.
    I started watching a movie after playing some minutes with some cds, dvds, etc.
    About 10 minutes into the movie the woofer made a strange noise (*plop*) and stopped working.
    It made a couple of more smaller plops and then stopped again.
    I stopped the movie.
    After 1 minute or so the subwoofer started to make noise by itself (movie was paused, no sound).
    It started to make loud rumbling noises, somewhat like thunder.
    It was very loud so I switched of the subwoofer via the power switch on the back.
    I took the power of the whole set and waited 30 minutes or so.
    I switched back on the set, but the woofer didn't work anymore.
    I checked cables, but those are ok. I also tried to set the woofer to loudest and to 160hz.
    I checked the settings to see if the subwoofer was set to "on".
    I ran the SmartEQ again, this worked, but only with a very low sound from the woofer.
    Barely audible. The SmartEQ results show that it couldn't detect the subwoofer, so it is now set to off.


    The strange thing is that a friend of mine has bought the same set 3 weeks ago.
    His set ran fine for a couple of weeks, but now he also has problems with the subwoofer.
    It almost doesn't work, but his woofer from time to time makes some strnage *plop* nooise, seemingly unrelated to the movie/music that is playing at that time.

    Is there anything we can try to make it work?
    I would be surprised that two (high-end) Philips parts are breaking so quickly after purchase.

    Another friend also received a HTR-9900 this week, but hasn't installed it yet.
    Do you recommend testing my set with his woofer?

    I bought the set via internet (new, official retailer) so if I need to return it will cost a lot of transport costs.

    Thanks,

    Valentijn

  2. #2
    New Member
    Points: 55, Level: 1
    Level completed: 5%, Points required for next Level: 95
    Overall activity: 10.0%
    Achievements:
    Tagger Second ClassNew Achievement!

    Join Date
    Jan 2013
    Location
    Eindhoven, The Netherlands
    Posts
    3
    Points
    55
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    EDIT: I just found a "Premium Service" folder inside the box of the receiver.
    This should give me repair/replace service at home!

  3. #3
    New Member
    Points: 55, Level: 1
    Level completed: 5%, Points required for next Level: 95
    Overall activity: 10.0%
    Achievements:
    Tagger Second ClassNew Achievement!

    Join Date
    Jan 2013
    Location
    Eindhoven, The Netherlands
    Posts
    3
    Points
    55
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Just been in touch with Philips Premium support that comes with this set.
    I will be contacted to plan a repair visit at my home.

Similar Topics

  1. Songbird DIED - is my expensive GoGear Connect 3 now useless?
    By DIJK in forum Sound: GoGear SA3-series (2011)
    Replies: 3
    Last Post: 02-20-2013, 01:34 PM
  2. My Streamium 1100 Just Died
    By nomad943 in forum Sound: Streamium NP Series (NP3900|NP3700|NP3500|NP3300|NP2900)
    Replies: 1
    Last Post: 12-23-2012, 02:15 AM
  3. HTS9140/98 Subwoofer no sound
    By Ed Canaya in forum Sound: Sound Bar (1.1 system)
    Replies: 7
    Last Post: 12-17-2012, 03:03 AM
  4. HTS8562/12: how is the surround experience / subwoofer
    By Markus77 in forum Sound: Immersive Sound (5.1 system)
    Replies: 2
    Last Post: 05-14-2012, 02:42 PM
  5. great test of Philips AV-Receiver/7.1-LS-Set HTR-9900
    By killerscorpio in forum Sound: Share Your Reviews
    Replies: 3
    Last Post: 02-15-2012, 09:32 PM

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •