Results 1 to 4 of 4

Topic: Wac7500

  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 45, Level: 1
    Level completed: 90%, Points required for next Level: 5
    Overall activity: 0%
    Achievements:
    New Achievement!

    Join Date
    Jan 2013
    Location
    Stoke
    Posts
    1
    Points
    45
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Wac7500

    I have had my music system for the last 3 years and this is the 2nd time I have had problems with the centre console. The first problem was fixed by Phillips and I was very happy with the service, however the main console has now stopped working again, the power light is flashing very quickly in and off and the system won't even come on, any ideas how I can fix this problem. I have rang the customer service line who were not to helpful to be honest and told me they would need to have it repaired to which a cost would be involved but couldn't say how much until they see it ??????

  2. #2
    Platinum Member
    Points: 2,996, Level: 15
    Level completed: 82%, Points required for next Level: 54
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsOverdriveNew Achievement!
    Awards:
    Discussion Ender
    Oscar's Avatar
    Join Date
    Feb 2011
    Posts
    722
    Points
    2,996
    Level
    15
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    4
    This looks indeed like a service case. Think the customer people don´t know and the price is for the service centre to tell. Maybe any other members have a clue

  3. #3
    New Member
    Points: 24, Level: 1
    Level completed: 47%, Points required for next Level: 26
    Overall activity: 4.0%
    Achievements:
    New Achievement!

    Join Date
    Jan 2013
    Posts
    2
    Points
    24
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    hi did you manage to solve this problem as mines the same?
    they was no use on the phone or online, they said it would be £179 just to look at it and this wont include mendng it!

  4. #4
    Silver Member
    Points: 2,977, Level: 15
    Level completed: 76%, Points required for next Level: 73
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Dec 2011
    Location
    birmingham/west midlands
    Posts
    125
    Points
    2,977
    Level
    15
    Thanks
    1
    Thanked 4 Times in 4 Posts
    Rep Power
    0
    Hi I had the same issue - it will probably be a power supply issue

    the power supply is no longer avaialble but i had mine repaired to component level by a philips recommended service agent - approx £120 been fine since

    Jh

Similar Topics

  1. WAC7500: Bass Stopped Working
    By amikolajczyk in forum Sound: Other Wireless Audio Models
    Replies: 4
    Last Post: 10-30-2012, 02:03 PM
  2. WAC7500 randomly disconnects from MCI500h
    By iansmith87 in forum Sound: Other Wireless Audio Models
    Replies: 13
    Last Post: 08-01-2012, 10:47 PM
  3. Moving from WAC7500 to MCi8080
    By woolaco in forum Sound: Streamium MCi series (MCi900| Mci8080| MCi730| MCi500| MCi298)
    Replies: 2
    Last Post: 05-22-2012, 11:29 AM
  4. Connecting WAC7500 to iPhone 4s ?
    By Vetti1979 in forum Sound: Other Wireless Audio Models
    Replies: 3
    Last Post: 03-27-2012, 01:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •