Results 1 to 3 of 3
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 44, Level: 1
    Level completed: 88%, Points required for next Level: 6
    Overall activity: 0%
    Achievements:
    New Achievement!

    Join Date
    Jan 2013
    Location
    Tenerife
    Posts
    1
    Points
    44
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Angry Philips SPA5300/10 Transstor Problem!!

    I have my SN product registered on this site. I have purchased my speakers only 20 days ago and am utterly disappointed that they already not working properly and that the problem is well known by Philips but have not taken it off the shelves. As I live in Tenerife where 15 days is the max time I can take a product back to get changed it will mean I have to take it to get fixed and it will take over 30 days. Now...I would not be as upset if Phillips would take the product line off the shelves or at least a particular batch well known for the transistor issue as I have come to find out!! Please note I do not have time to mess around and play okey pokey it costs money and time to go get it fixed!! Even if the fix is free I still have to now wait for it to get fixed. This is not right!! Not when you know your product is no good on particular batches!!

  2. #2
    Platinum Member
    Points: 2,996, Level: 15
    Level completed: 82%, Points required for next Level: 54
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsOverdriveNew Achievement!
    Oscar's Avatar
    Join Date
    Feb 2011
    Posts
    722
    Points
    2,996
    Level
    15
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    4
    How do you know that yours is of a wrong Batch? Whats your Sn? It looks indeed there are batches that are faulty ( like with my car, laptop, mcirowave and others....) but don´t think they took them of the market....no way

  3. #3
    New Member
    Points: 12, Level: 1
    Level completed: 23%, Points required for next Level: 38
    Overall activity: 0%
    Achievements:
    New Achievement!

    Join Date
    Aug 2014
    Posts
    1
    Points
    12
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Dear Sir,
    Im using Philips SPA5300/10 for 1 month and facing same problem table volume top led is blowing brighter and some time became dim sound gos off. My speaker SN is JT1A1130000371. Please revert same has been with resistor problem batch or any other. Plz Revert..

Similar Topics

  1. Phillips SPA5300/10 problem
    By Wolk in forum Sound: Other Models
    Replies: 96
    Last Post: 06-10-2014, 12:05 PM
  2. SPA5300/10 Problem
    By EmoObama in forum Sound: Sound Hub (2.1 system)
    Replies: 0
    Last Post: 08-20-2012, 05:35 PM
  3. Problem Philips 32PFL5405H/12
    By milenkomudri in forum TV: Other
    Replies: 2
    Last Post: 02-10-2012, 10:41 AM
  4. Philips Wi-fi Mediaconnect big problem
    By Cruzeros in forum TV: Streaming & Network
    Replies: 1
    Last Post: 08-08-2011, 05:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •