Hello all,

I'm experiencing severe issues with HDMI connections on my 42PFL7606H1/2 in combination with an Onkyo TX-NR515 AVR receiver and a RaspberryPi running XBMC which is connected to AUX on the AVR.

The problems began yesterday. This is going to be a long post as I've already done much testing and made a lot of observations, I really already tried lots of possible solutions, in order:

1. Try other HDMI input on TV
2. Try secondary HDMI output on AVR
3. Update TV firmware from 101 to 104 (AVR is already using latest firmware)
4. Reset to factory defaults of Onkyo AVR
5. Soft reset by leaving both the TV and AVR unplugged from the mains (for 15 hours)
6. Connecting AVR to Samsung TV. Works without problems.
7. Reset to factory defaults of Philips TV

I was expecting step 6 to fail, but it didn't, so it isn't the AVR itself. As a last resort I reset the TV which I expected to resolve at least some peculiarities, but you guessed it, no improvements at all.

What does work

- Easylink remote (changing of volume)
- Video input from RPi through AVR

What doesn't work

1. ARC
2. Some video input from AVR (not even blue "No source" video from AVR, or NET view, or setup view. Only if RPi is active source then setup/OSD's are visible)
3. Recognizing of HDMI connected devices


1. ARC

Everything is setup correctly, I checked and tried and checked again but no luck. The TV does correctly detect the AVR and disables its internal speakers. The AVR does not however pick up any audio. When I go to Easylink settings and enable the TV speaker, I have sound and the AVR displays "TV speakers" and mutes. When I go back to Easylink or unmute the AVR, it displays "AMP speakers" (so recognizes a switch) but no sound. Also, no ARC icon is displayed on the OSD.

Note: I tried with an S/PDIF cable from Optical audio out on TV to Optical 1 on the AVR, that does work. It really is HDMI which is nagging me.

2. Video input
Only if the active source on the AVR is my RPi, I get the image and also the OSD's/menu's on top of it. When I switch to any other source, I expect a blue screen (for no input on AVR) but the TV says there is no input. Even the NET functionality doesn't give any image. Because of this I really thought the AVR is faulty (I've had problems before) so that was the reason to hook up the AVR to a Samsung TV. Everything worked flawlessly, even the problem described in above link was not present.

3. Recognizing of HDMI connected devices
XBMC was always nicely recognized in the home screen of the TV. Now, it is recognized twice (!) and when I hover over it it shows "undefined", which normally would be "HDMI1" (the connected port). Clicking it doesn't do anything. Now comes the funny/weird part: I first delete one device from the home screen, which cause the second one to also be deleted, then connect the RPi directly to HDMI Side (AVR no longer involved) and then rebooting the RPi will add the device back to the home screen, once this time. However, when I hover over it it says: "HDMI1", that's my AVR, which I just circumvented. So clicking it indeed switches to HDMI1 and there is no source available, obviously. Thus I unplug the RPi from HDMI Side back into AVR AUX, and there you go, the remote control successfully controls XBMC, like it always has until recently.

I expected this to be solved by a factory reset, but still the very same problem.

Wrapping Up
The ARC and recognition of devices is probably a software bug. The "No input" problem however and also the problems I have as explained in the previously linked thread appear like a faulty HDMI board or something. I first blamed the AVR but now that I've seen it working flawlessly on a Samsung TV, I'm accusing my TV instead.

Thanks for reading if you've come this far.