Results 1 to 4 of 4
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 40, Level: 1
    Level completed: 80%, Points required for next Level: 10
    Overall activity: 13.0%
    Achievements:
    Tagger Second ClassNew Achievement!

    Join Date
    Mar 2013
    Location
    Nedre Eiker, Buskerud, Norway
    Posts
    3
    Points
    40
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    5.1 sound not forwarded through SPDIF (optical)

    I have a sound problem. My system is connected like this:

    A PlayStation 3 connect to my Philips 47PFL6907 TV using HDMI.
    A Sony Dolby Digital receiver connect to the TV using SPDIF (optical).

    When the PS3 sends 2 channel sound everything is OK.
    Sound on both the TV and through the receiver (showing "Dolby DIgital 2.0").

    But when I use programs that send 5.1 sound on the PS3 then:
    Sound on the TV, and the receiver displays "Dolby Digital 5.1".
    BUT there is no sound at all from the speaker on the receiver :-(

    What could be wrong?
    The TV has obviously detected the 5.1 sound input from the PS3 as it signals the deciever to change to 5.1.
    But why isn't there any sound from the receiver?

    Have tried all setting on all components without any result.
    Only thing that helps is forcing the PS3 to send 2.0 output.
    But then I get no surround sound in games or from DVD/BD :-(

    I can of course connect the SPDIF (optical) directly from the PS3 to the receiver.
    I know that works. But then I can't get any sound from the TV to the receiver.
    And I get problems with the video delay (TV usually compensate for that).

    I had a Philips TV with coax digital out earlier, and that all was OK.
    Anyone have any idea on what couød be the problem now?

    PS! Even stranger; if I watch a TV channel transmitting 5.1 sound THEN there is 5.1 sound from the receiver.
    So I is only when the TV should forward 5.1 sound that the problem occurs.

  2. #2
    Silver Member
    Points: 3,256, Level: 16
    Level completed: 52%, Points required for next Level: 194
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsOverdriveNew Achievement!

    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    127
    Points
    3,256
    Level
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    4
    I think that´s a audio bit rate problem (high big rate for TV), can you output 5.1 PCM (not raw or bitstream) from PS3 and try it if works.

  3. #3
    New Member
    Points: 40, Level: 1
    Level completed: 80%, Points required for next Level: 10
    Overall activity: 13.0%
    Achievements:
    Tagger Second ClassNew Achievement!

    Join Date
    Mar 2013
    Location
    Nedre Eiker, Buskerud, Norway
    Posts
    3
    Points
    40
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Manuel View Post
    I think that´s a audio bit rate problem (high big rate for TV), can you output 5.1 PCM (not raw or bitstream) from PS3 and try it if works.
    I have tried disabling Dolby Digital 5.1. output on the PS3 and enabling PCM 5.1.
    But then I get no sound at all when 5.1 sound. Not even on the TV.

    The strange thing is that when Dolby Digital 5.1 sound is on and send from the PS there is sound from the TV speakers.
    The sound is just not forwarded to the receiver on SPDIF (optical). The receiver even change to 5.1 mode, but no sound.

    To sum up what connections and modes work or not:

    PS3 2.0 Dolby Digital -> HDMI -> TV speaker OK -> SPDIF -> Dolby Digital 2.0 on receiver OK
    PS3 5.1 Dolby Digital -> HDMI -> TV speaker OK -> SPDIF -> Dolby Digital 5.1 but no sound

  4. #4
    Silver Member
    Points: 3,256, Level: 16
    Level completed: 52%, Points required for next Level: 194
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsOverdriveNew Achievement!

    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    127
    Points
    3,256
    Level
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    4
    I don't now if it's only for tuner, but try to change audio settings on:
    Home » Channel settings » Languages » Preferred audio format » try the options 1 standard 2 advanced

    Which firmware do you have on tv?

Similar Topics

  1. RTL XL app, sometimes no sound through spdif out
    By rollufje in forum Smart TV: Software
    Replies: 1
    Last Post: 03-03-2013, 08:19 PM
  2. 5.1 sound from HTS3538/12 via SPDIF
    By bubesa in forum Sound: Home Cinema Sound
    Replies: 2
    Last Post: 02-11-2013, 06:01 AM
  3. DVB-T optical out sound format
    By bo1e in forum TV: Connectivity
    Replies: 8
    Last Post: 05-26-2012, 09:50 AM
  4. Replies: 12
    Last Post: 02-03-2012, 12:40 PM

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •