I just bought an HTS5563/12 system. The current software version is 1.09.06.4. When I try to do a software upgrade, it gives me the error "Upgrade verification failed". Doesn't matter if I try to upgrade over internet or USB.

What is the problem and how do I solve this?