Results 1 to 6 of 6
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 187, Level: 2
    Level completed: 37%, Points required for next Level: 63
    Overall activity: 13.0%
    Achievements:
    New Achievement!31 days registered100 Experience Points

    Join Date
    Mar 2013
    Posts
    3
    Points
    187
    Level
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    problems posting a new thread - MCi300 registration and streamium problem

    guys
    I posted a new thread a few days ago about my MCi300 registration and problems with streamium management. it hasnt appeared on the forum. Have i done something wrong?

  2. #2
    Moderator
    Points: 1,479, Level: 10
    Level completed: 65%, Points required for next Level: 71
    Overall activity: 0%
    Achievements:
    New Achievement!3 months registered1000 Experience Points
    Philips - Tereza's Avatar
    Join Date
    Feb 2013
    Posts
    184
    Points
    1,479
    Level
    10
    Thanks
    9
    Thanked 9 Times in 8 Posts
    Rep Power
    10
    Hi ernie29,

    under what username (nickname) did you post the new thread few days ago?

    Philips Moderator Team
    Forum Mod

  3. #3
    New Member
    Points: 187, Level: 2
    Level completed: 37%, Points required for next Level: 63
    Overall activity: 13.0%
    Achievements:
    New Achievement!31 days registered100 Experience Points

    Join Date
    Mar 2013
    Posts
    3
    Points
    187
    Level
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I posted using ernie29. I will try again....
    I bought an MCI300/12 Streamium Wireless Micro Hi-Fi System just over two years ago and have been delighted with it. However, at the end of the first week in December 2012 my internet radio feature stopped working. The error message I was getting said that the device could not access a server, so I suspected that the problem was with Philips. I called the support number and after some checks, it was confirmed that Philips had made changes to the internet radio service and that this was affecting multiple customers. I was advised that an agent would call me back with an update and that the problem would be rectified soon. To cut a long story short, I have called back many times over the last four months but I am still having problems. One of the suggestions was that Philips would delete my account and I would have to re-register my email address and my MCI300 to pick up the new service. I did this by updating the firmware to the latest level, resetting everything back to factory defaults and re-registering using the MCi300 to enter my email address and then following the link that I received as an email to register the product. Even when the product was re-registered, the Streamium Management system doesn’t allow me to configure my internet radio service (it just hangs). Also, when I select internet radio on the MCi300, instead of getting a list of radio stations, I am asked to register the device by entering an email address (although the Philips website says that the device is registered). I have tried to register again, but this hasn’t helped matters.

  4. #4
    Moderator
    Points: 1,479, Level: 10
    Level completed: 65%, Points required for next Level: 71
    Overall activity: 0%
    Achievements:
    New Achievement!3 months registered1000 Experience Points
    Philips - Tereza's Avatar
    Join Date
    Feb 2013
    Posts
    184
    Points
    1,479
    Level
    10
    Thanks
    9
    Thanked 9 Times in 8 Posts
    Rep Power
    10
    Dear ernie29,

    please send me a private message with the following details and we will have a look into it.

    1) product registration ID - the email address under which you registered your internet radio account
    2) serial number of the product
    3) MAC address - as written on the label on the product or displayed in the setting menu

    Thank you very much.

    Kind Regards,

    Philips Moderator Team
    Forum Mod

  5. #5
    New Member
    Points: 12, Level: 1
    Level completed: 23%, Points required for next Level: 38
    Overall activity: 0%
    Achievements:
    New Achievement!

    Join Date
    Jun 2013
    Posts
    1
    Points
    12
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi,
    Did it work ?
    I have the same problem, I cannot register my MCI300 and therefore is unable to connect to the internet server. I have tried to register a new account, but with no success.

    Regards Lars J

  6. #6
    New Member
    Points: 187, Level: 2
    Level completed: 37%, Points required for next Level: 63
    Overall activity: 13.0%
    Achievements:
    New Achievement!31 days registered100 Experience Points

    Join Date
    Mar 2013
    Posts
    3
    Points
    187
    Level
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Lars J View Post
    Hi,
    Did it work ?
    I have the same problem, I cannot register my MCI300 and therefore is unable to connect to the internet server. I have tried to register a new account, but with no success.

    Regards Lars J
    Lars
    Yes, eventually, it did work. The instructions I followed were as follows:-

    Please start all over again -> reset your device ->register your device -> wait for the email confirmation -> confirm the registration -> login in to the internet radio

    It took several attempts over three or four weeks and I am pretty sure that someone did something behind the scenes to fix the problem. Has someone from the support team picked up your request for help? I had to provide my user name and password through the private messaging facility to allow them to look at my account in detail before the problem was resolved.

Similar Topics

  1. Streamium WAC700/05 Boot Problems
    By jokab in forum Sound: Other Wireless Audio Models
    Replies: 6
    Last Post: 06-15-2014, 03:45 PM
  2. problem with regard registration at Net TV service
    By sistemf in forum Smart TV: Installation
    Replies: 12
    Last Post: 05-22-2013, 05:31 PM
  3. Philips MCi300/05 Wireless Micro HiFi System problem
    By SteveinFrance in forum Sound: Mini/Micro Audio System Product Support
    Replies: 5
    Last Post: 04-04-2013, 09:23 AM
  4. Mci300/12
    By blueritchi3 in forum Sound: Other Wireless Audio Models
    Replies: 0
    Last Post: 03-07-2012, 02:01 PM
  5. problem managing my Streamium SL400i over Club Philips
    By pfuhli in forum Sound: Other Models
    Replies: 6
    Last Post: 09-12-2011, 11:35 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •