Results 1 to 2 of 2
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 16, Level: 1
    Level completed: 31%, Points required for next Level: 34
    Overall activity: 0%
    Achievements:
    Tagger Second ClassNew Achievement!

    Join Date
    Jun 2013
    Posts
    1
    Points
    16
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Angry DS9800 Buttons, everything stopped working but still GREEN

    Okay so I just came back from my holidays and I think I may have left my DS9800 on the entire time however, I see no reason why it should all of a sudden stop working.

    Essentially, all the buttons do not respond, including the remote control functions. I ensured a new battery was placed in yet nothing has worked. The speakers still light up a solid green as in nothing is wrong - but I cannot connect to it, cannot reset it and its quite frustrating. I tried doing a hard reset (5 sec hold) - it doesn't respond. I try unplugging and replugging it to force it to restart, still nothing, it just lights up back GREEN and doesn't even blink or anything. The wifi setup button doesn't work either. Just ALL buttons have stopped working.

    Although it did start blinking green for 35 seconds before turning red blinking twice in the 35 unplug and replugs I have done to 'hopefully' fix this thing!

    Has anyone else encountered this problem? Is there an easy fix? I live in London and its a pain to send these speakers in because they are so big nor did I keep the original packaging.

    Regards,
    Harry

    I bought these speakers over Amazon US in November 2012. I am not sure what to do now. They were such amazing speakers and its a shame they aren't working now!

    It seems like many others are having the same situation as me, few months in and the product stops working. Given such a frequent occurrence, I think a legal class action lawsuit could be worth looking into here? I know a good lawyer who would be interested in such cases.
    Last edited by tsunyuen; 06-09-2013 at 01:43 AM.

  2. #2
    Silver Member
    Points: 647, Level: 6
    Level completed: 49%, Points required for next Level: 103
    Overall activity: 33.0%
    Achievements:
    New Achievement!3 months registered500 Experience Points

    Join Date
    Feb 2013
    Posts
    125
    Points
    647
    Level
    6
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Rep Power
    2
    hi tsunyuen, i can imagine that this is frustrating. however, as in the mentioned thread about the similar issue, I would try to take it to your local authorized Philips service centre and have it fixed. it worked for lots of users. have a go!

Similar Topics

  1. Buttons not working
    By Nuffler in forum Sound: DS8000- and DS9000-series
    Replies: 11
    Last Post: 01-29-2014, 06:48 PM
  2. WAS7500/05 Stopped Working
    By jsugrue in forum Sound: Other Wireless Audio Models
    Replies: 4
    Last Post: 04-09-2013, 11:09 AM
  3. Remote stopped working
    By MaisyP in forum TV: Other
    Replies: 1
    Last Post: 11-09-2012, 02:20 PM
  4. Sound has stopped working
    By cybertalis in forum Sound: Other Wireless Audio Models
    Replies: 1
    Last Post: 08-04-2012, 03:40 PM
  5. Gogear Opus 16b Buttons have stopped working.
    By Dearkax in forum Sound: GoGear SA1-series (2009)
    Replies: 2
    Last Post: 11-22-2011, 09:29 AM

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •