Results 1 to 7 of 7
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 1,311, Level: 9
    Level completed: 81%, Points required for next Level: 39
    Overall activity: 0%
    Achievements:
    New Achievement!1 year registered1000 Experience Points

    Join Date
    May 2012
    Location
    Castro / Chile
    Posts
    7
    Points
    1,311
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    MCI900 numerous issues

    I really like my MCI900, please don't misunderstand me. The sound is amazing and the capabilities are ok. However, it has just too many problems, with a list which seems to be growing with each firmware update. I have found myself many of whom I have not seen in any other thread, so I decided to start a new one.

    1. When playing a CD, it skips the first 1 - 2 secs

    2. EVERYTIME I play a CD, the sound is distorted, full of clipping. For the sound to "normalize", I have to modify the settings through the TV (they cannot be accessed directly in the LCD screen, I think the CDs are recognized as some kind of DVD): I must go to Audio / Sound Mode / Music Mode and pick any option. Then the sound gets lower and without clipping. Unfortunately, this setting doesn't stick and has to be done again for every CD.

    3. The shuffle option for playlists in the HD is no real shuffle, it's kind of a different sorting. I mean, each time you pick the playlist, all tracks are played in the same order. If you stop and choose to play the same playlist again, a different order is played, but every second time the order is the same. The same happens for the third, fourth time and so on. After having to stop and play 10 times to get a different order, the thing is not funny anymore.

    4. It freezes a lot, giving you a blank screen. The only way to get it back is unplug the power.

    5. When playing files from the HD, sometimes it stops playing and gives the following message: "The media server is currently not available. Press <STOP> and try again"

    6. The resume feature works only sometimes. I haven't figured out a patron, I have observed a pretty random behavior. This feature may partially solve #3.


    This ones may not be considered bugs in a strict definition, but I think shall also be fixed:

    1. Video files can't be played from USB, they must be recorded in a CD or DVD.

    2. There is no way to build a playlist on the fly in the player (they must be created in a PC). You may play all files in the HD when pressing PLAY in All Files, but the same procedure over, for example, Genre jumps into the content of it. You must be on the last folder of a category to be able to play everything in it. You cannot play, for example, all tracks from a single Artist, but you can play all the tracks from an album of that Artist. This makes the whole organization in Genres, Artists and so on useless.

    3. HDMI output shall have a video-only option (other that turning the sound off in the TV). If I play a movie in my MCI900, of course I want to hear the movie through the high quality speakers of it instead of the small speakers of the TV. If both are playing, there is a small delay in the TV which causes the sound to have some kind of echo.


    I am pretty sure that everything may be fixed or improved through a firmware update, but I may be wrong.

    Thanks in advance for any advice or comment.
    Last edited by mzecher; 08-25-2013 at 05:46 PM. Reason: Added some points

  2. #2
    Moderator
    Points: 1,216, Level: 9
    Level completed: 33%, Points required for next Level: 134
    Overall activity: 9.0%
    Achievements:
    New Achievement!3 months registered1000 Experience Points
    Philips - Joanna's Avatar
    Join Date
    Feb 2013
    Posts
    58
    Points
    1,216
    Level
    9
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    10
    Hi Mzecher,

    Thank you for your feedback regarding your MCI900. We appreciate the time you devoted to writing this review. I have already passed your comments to the Development Team who are constantly working on improving the quality of our products.

    I will keep you updated once I receive an answer back from the Team.

    Kind regards,

    Joanna
    Philips Moderator Team
    Forum Mod

  3. #3
    New Member
    Points: 1,311, Level: 9
    Level completed: 81%, Points required for next Level: 39
    Overall activity: 0%
    Achievements:
    New Achievement!1 year registered1000 Experience Points

    Join Date
    May 2012
    Location
    Castro / Chile
    Posts
    7
    Points
    1,311
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for the response Joanna, I will keep tuned. Hopefully the listed problems may be fixed by firmware side.

  4. #4
    New Member
    Points: 1,311, Level: 9
    Level completed: 81%, Points required for next Level: 39
    Overall activity: 0%
    Achievements:
    New Achievement!1 year registered1000 Experience Points

    Join Date
    May 2012
    Location
    Castro / Chile
    Posts
    7
    Points
    1,311
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I haven't receive any answer nor comment on this yet.

    Today I updated to latest software version (C9.38S). I will check how everything goes and let you know if I find some of this issues fixed.

  5. #5
    New Member
    Points: 1,311, Level: 9
    Level completed: 81%, Points required for next Level: 39
    Overall activity: 0%
    Achievements:
    New Achievement!1 year registered1000 Experience Points

    Join Date
    May 2012
    Location
    Castro / Chile
    Posts
    7
    Points
    1,311
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    After using extensively this version (C9.38S), I concluded that not even a single bug of my list have been fixed.

    Even worse, it added a new bug: About 1/4 times you suspend and then turn on the device, the volume of the speakers gets so low, it almost can't be heard (even if you put it at maximum). This doesn't affect other devices, such as a TV (I mean, connected through HDMI or RCA cables). The only way I've found to recover the original volume is to turn the device completely off (suspending doesn't fix it) and then on again.

    I couldn't report this before, since the forum was down for about a month.

    It's really frustrating that with each release, not only existing bugs are not fixed, but also new bugs are introduced. This device is available since more than 3 years now. With such amount of time running out, I would expect the firmware to be almost bugless, or very polished at least. I'm really thinking of buying a new thing if no detailed information in the status of this bugs is given by Philips.

  6. #6
    New Member
    Points: 103, Level: 1
    Level completed: 53%, Points required for next Level: 47
    Overall activity: 8.0%
    Achievements:
    New Achievement!31 days registered100 Experience Points

    Join Date
    Jan 2014
    Posts
    5
    Points
    103
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Mzecher
    No answers to your problems but total sympathy. Except for the speaker issue I have had all the problems you have listed. I have spent £240 in repairs when the system (just outside warrant period) was completely inoperable.
    The shuffle now no longer works. Considering this was a major selling point for the system I have come to the conclusion that the system is not fit for purpose.
    Forget about Philips Support is my advice. From personal history they are as useful as the system they market.
    Jeffers

  7. #7
    New Member
    Points: 1,311, Level: 9
    Level completed: 81%, Points required for next Level: 39
    Overall activity: 0%
    Achievements:
    New Achievement!1 year registered1000 Experience Points

    Join Date
    May 2012
    Location
    Castro / Chile
    Posts
    7
    Points
    1,311
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks a lot jeffers, it's good to know that I'm not alone. I just hope that we were able to somehow force Philips to fix at least the most severe problems. I already discouraged a few friends from buying this device. The sound quality and the supposed to work features are tempting I guess.

    I regret not finding a thread like this one when I googled for reviews of this device. It's hard to believe that you will get such a customer experience and bug-full device from a known company.

Similar Topics

  1. MCI900/12 spares
    By Hyper in forum Sound: Streamium MCi series (MCi900| Mci8080| MCi730| MCi500| MCi298)
    Replies: 0
    Last Post: 01-26-2013, 03:47 PM
  2. MCi900 DVD player
    By MidnightManiac in forum Sound: Streamium MCi series (MCi900| Mci8080| MCi730| MCi500| MCi298)
    Replies: 3
    Last Post: 01-09-2013, 03:59 AM
  3. Philips MCI900 Streamium numerous faulty
    By Tronnalzm in forum Sound: Streamium MCi series (MCi900| Mci8080| MCi730| MCi500| MCi298)
    Replies: 1
    Last Post: 06-08-2012, 12:00 AM
  4. MCi900
    By Rollouk63 in forum Sound: Streamium NP Series (NP3900|NP3700|NP3500|NP3300|NP2900)
    Replies: 1
    Last Post: 06-04-2012, 04:25 AM
  5. Spotify is now available on MCi900
    By Philips - Andrea in forum Sound: Streamium MCi series (MCi900| Mci8080| MCi730| MCi500| MCi298)
    Replies: 13
    Last Post: 02-15-2012, 12:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •