Results 1 to 5 of 5
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 50, Level: 1
    Level completed: 33%, Points required for next Level: 100
    Overall activity: 6.0%
    Achievements:
    New Achievement!7 days registered

    Join Date
    Jul 2013
    Posts
    2
    Points
    50
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Broken Wacs700.

    I've sent my Philips Wacs 700 to the repairers via the Philips website.
    They have told me the unit is unrepairable due to an electronic board no longer being available.
    This leaves me stuck with a 705 and two 7005 stations which are now useless.

    Is this not particularly poor form for an official repairer not to be able to get hold of the right parts? Or should I expect to have to replace my music centres every 6 years?

  2. #2
    Silver Member
    Points: 822, Level: 7
    Level completed: 36%, Points required for next Level: 128
    Overall activity: 15.0%
    Achievements:
    New Achievement!3 months registered500 Experience Points
    William Wallace's Avatar
    Join Date
    Feb 2013
    Location
    Scotland
    Posts
    160
    Points
    822
    Level
    7
    Thanks
    0
    Thanked 12 Times in 12 Posts
    Rep Power
    2
    Hi Bushido UK,

    As this is a user-to-user community forum, I'd suggest contacting your local Customer Support about this case. From your nick I gather you're from the UK? This may help http://www.support.philips.com/suppo...userCountry=gb

    I'm sure if you speak to someone from Philips there, they will try and help.

    Good luck!
    WW

  3. The Following User Says Thank You to William Wallace For This Useful Post:

    BushidoUK (08-08-2013)

  4. #3
    New Member
    Points: 50, Level: 1
    Level completed: 33%, Points required for next Level: 100
    Overall activity: 6.0%
    Achievements:
    New Achievement!7 days registered

    Join Date
    Jul 2013
    Posts
    2
    Points
    50
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yeah, have been in touch with Philips support. They can't / won't do anything as they no longer support this old system. (bought 2006)

    Its not so much the system has failed and is unrepairable, its the fact Ive bought stations to go long with it, which are now only good as oversized radios.

    I just think its particularly poor that Philips don't even sell a product that I can use these stations with.

    Will end up putting the stations on ebay and replacing the stations with SONOS products.

  5. #4
    New Member
    Points: 1,040, Level: 8
    Level completed: 45%, Points required for next Level: 110
    Overall activity: 9.0%
    Achievements:
    New Achievement!1 year registered1000 Experience Points

    Join Date
    Mar 2012
    Location
    Glasgow
    Posts
    3
    Points
    1,040
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I'm having a similar problem, my WAC7500 stopped working a few days ago, the power LED was constantly flashing red. I opened the unit, and found all the capacitors on one of the PCB's had leaked.

    The date on the board was 27/08/2007, so it's not quite six years old yet. I haven't tried contacting philps yet, but I'm not hopeful that it can be easily repaired.
    Last edited by MrProsser; 08-10-2013 at 02:30 PM.

  6. #5
    Silver Member
    Points: 822, Level: 7
    Level completed: 36%, Points required for next Level: 128
    Overall activity: 15.0%
    Achievements:
    New Achievement!3 months registered500 Experience Points
    William Wallace's Avatar
    Join Date
    Feb 2013
    Location
    Scotland
    Posts
    160
    Points
    822
    Level
    7
    Thanks
    0
    Thanked 12 Times in 12 Posts
    Rep Power
    2
    Yeah I know it's upsetting each time anything stops working and it always drives me mad too. 6 years is quite a long time tbh though and with all the tech advances I'm sure you can find a cheaper and newer replacement.

    Good luck!
    WW

Similar Topics

  1. WACS700 CD player failure
    By rosieloumid in forum Sound: Other Wireless Audio Models
    Replies: 5
    Last Post: 07-19-2013, 03:12 AM
  2. WACS700 CD player failure
    By rosieloumid in forum Sound: Other Wireless Audio Models
    Replies: 1
    Last Post: 07-01-2013, 09:31 AM
  3. HTS 9800 W amp broken
    By NIKI in forum Sound: Home Cinema Sound
    Replies: 1
    Last Post: 03-04-2013, 08:57 AM
  4. wacs700 and mac osx itunes
    By thewall in forum Sound: Other Wireless Audio Models
    Replies: 3
    Last Post: 12-20-2012, 11:55 AM
  5. Broken TV :-(
    By 26ct509 in forum TV: Other
    Replies: 0
    Last Post: 07-14-2012, 06:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •