Hi,
I have 2 of these TVs. One had not been used for at least 2 years, the other was being used primarily as an hdmi monitor.

I connected the unused to a stb via hdmi, and it worked fine. I think it was sw version 25.33.9 (?), dated around May 2009. It connected to my wireless network without issue and reported 36mps connections speed. When trying to launch net tv, it would hang at the agreement page, as the ok was not highlighted, and cursor seemed to do nothing. I attempted a sw upgrade via network, and it began, but immediately shut off, never to turn back on. Now it seems bricked. If I leave ac unplugged for about a minute or more, then upon plugging in, it will flash white led and show the blue philips splash screen, then go off, then flash the red led 3 times, pause, flash it again 3 times, repeating......

I then went to my monitor, which I know I had performed a sw upgrade via network in the past, but it was only an early version of 26.x. It exhibited the same hang on net tv entry, although I have used it for YouTube and other apps in the past, both wired and wirelessly. It said there was an upgrade, but instead of risking to brick that one also, I proceeded by downloading the file from the website, extracting the auto run.pug, putting on a fat32 stick by itself, and performing upgrade manually. Same result.

Now I cannot power on either set. I either get philips logo for a few seconds the shuts off, or I get nothing but 3 red led flashes.

Any help that anyone can provide to recover these sets? Is there any type of recovery process via renaming the file to something special, downgrading, using a secret process?

Thanks.