Results 1 to 2 of 2
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 21, Level: 1
    Level completed: 41%, Points required for next Level: 29
    Overall activity: 0%
    Achievements:
    New Achievement!

    Join Date
    Jan 2014
    Posts
    2
    Points
    21
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    HTR5224 can't save speaker vol and wrong display status -- any firmware to fix?

    As title. I have just got this Philips HTR5224 AV receiver last weekend and connected it. It works, but I found its' Center speaker's volume is a bit low (the character voice in movie is not stand out enough) so I want to increase the center speaker volume a bit. The user manual is definitely brief enough. I tried to set by:

    0) For an instance, the current master volumen level is "Vol. 10"
    1) get in "Audio Setup" => "Test Tone", then press OK to get in
    2) then see from front LED panel and hear from speakers that test tone was played to each speaker one by one, FL->CENTER->FR->SUR L->SUR R->BL (funny thing is my unit show FL again for BL speaker)->BR-> SUB W. Each speaker will play test tone for about 3-4 second. Each one will also display VOL 10 if I haven't changed anything
    3) Then I wait till the test tone rotate back to "CEN VOL 10", then I immediately use "VOL +" button to try increase the CENTER speaker volume (say, add to VOL 13), then press OK to confirm. It will end my TEST TONE sequence. LED panel show "TEST TONE" again. (User manual said after I pressed OK, I should wait for 5 seconds)
    4) now the front panel will back to "TEST TONE". I thought the VOL +3 setting for CENTER has been saved. But when I try playing movie again, seems no change;
    5) Then I get in "TEST TONE" mode again. During the test tone rotating through each speacker, I see each channel is at "VOL 13", not only CENTER is VOL 13.
    6) Then I tried to let the rotation complete -- set master VOL 10, start TEST TONE, wait till CENTER then VOL +3 (CENTER VOL13), then set VOL -3 at next channel (FR VOL 10), then no more change to ensure each other channels are also VOL 10 except CENTER. Wait till it rotate to SUB W then press OK
    7) Then retest again. Seems all channels have the same volume again. Go back to TEST TONE and see all channels at VOL 10.

    Anyone can teach me how to set volume for each individual speaker? Also, I found my HTR5224 is not very much stable especially with HDMI input. And some of the display on LED panel are incorrect. I found there is a software update port at the rear. Anyone got the latest update software of HTR5224/12?

    Please kindly offer some helps to me! Really thanks a lot!!

  2. #2
    New Member
    Points: 21, Level: 1
    Level completed: 41%, Points required for next Level: 29
    Overall activity: 0%
    Achievements:
    New Achievement!

    Join Date
    Jan 2014
    Posts
    2
    Points
    21
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    One more problem. I've just found out that if I bitstream DTS to HTR5224 and let it decode, the sound quality is quite bad. But if I decode on the player side (PC) then output LPCM through HDMI or optical, the sound will be much better. Tonight I will find Dolby Digital AC3 movie to test also. I switched to all kind of sound mode but bitstream + decode by HTR5224 is still much worse than decode by other devices. Any HTR5224 owners also observed this?

    Thanks a lot!

Similar Topics

  1. BDP3000/98 uploaded wrong firmware
    By bgf9025 in forum Blu-ray: BDP2000 & 3000 Series
    Replies: 3
    Last Post: 12-02-2013, 12:13 PM
  2. Digital AV receiver system HTR5224
    By ErvinC in forum Sound: Home Cinema Sound
    Replies: 2
    Last Post: 05-23-2013, 02:09 PM
  3. Wrong Firmware Philips Fidelio SoundSphere DS9800W
    By ChadBarba in forum Sound: DS8000- and DS9000-series
    Replies: 3
    Last Post: 03-29-2013, 03:41 PM
  4. Wrong click in Display-Settings
    By Santa Maria in forum Sound: Streamium NP Series (NP3900|NP3700|NP3500|NP3300|NP2900)
    Replies: 0
    Last Post: 06-29-2012, 10:53 AM
  5. VBE04BN/02 After apply firmware - Display off
    By ovx in forum Sound: GoGear SA3-series (2011)
    Replies: 1
    Last Post: 02-16-2012, 08:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •