Page 2 of 2 FirstFirst 12
Results 16 to 17 of 17
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #16
    Moderator
    Points: 6,733, Level: 24
    Level completed: 37%, Points required for next Level: 317
    Overall activity: 99.8%
    Achievements:
    New Achievement!3 months registeredOverdrive5000 Experience Points
    Philips - Rafal's Avatar
    Join Date
    Oct 2013
    Posts
    1,091
    Points
    6,733
    Level
    24
    Thanks
    23
    Thanked 42 Times in 39 Posts
    Rep Power
    10
    Hi Neil,

    I'm afraid that won't be covered. Please accept my apologies.

    Kind regards,
    Philips Moderation Team

  2. #17
    Bronze Member
    Points: 2,403, Level: 13
    Level completed: 85%, Points required for next Level: 47
    Overall activity: 6.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Sep 2011
    Location
    Oxford
    Posts
    47
    Points
    2,403
    Level
    13
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    No worries - thanks for your efforts.

    However, I wouldn't be able to justify spending any money on getting this unit repaired - it has been a serious disappointment from the start I'm afraid.

    I had a Philips TV which worked well for 15 years, and I thought I was buying a solid product when I chose my Blu-ray player. Based on my experiences with the BDP5200, my respect for Philips as a brand has effectively been wiped out.

    Having said that, there's one bit of good news: in desperation, I tried a few more times to reset the unit to factory default settings. During one of those sessions, I also re-tried the option to clear the NetTV (wrong spelling?) memory, and my suspicion is that that's what made the difference. Whatever the cause, the unit now plays happily for hours without hanging - apparently it's fixed.
    So if anyone else is reading this with the same problem - try clearing the NetTV memory as well as resetting to factory defaults, and good luck...

    regards
    Neil

Page 2 of 2 FirstFirst 12

Similar Topics

  1. BDP5200 won’t playback sound in AVI files
    By Steve_13 in forum Blu-ray: BDP5000 & 6000 Series
    Replies: 0
    Last Post: 08-16-2013, 11:26 PM
  2. EPG is one hour late.
    By status70 in forum TV: Other
    Replies: 0
    Last Post: 12-18-2012, 06:11 PM
  3. Video playback keeps freezing
    By royd_68 in forum TV: Streaming & Network
    Replies: 0
    Last Post: 10-27-2012, 05:06 PM
  4. Video playback via USB - sticks @ 50 minutes - BDP5200/05
    By evilarty in forum Blu-ray: BDP5000 & 6000 Series
    Replies: 2
    Last Post: 06-16-2012, 04:27 PM
  5. Philips BDP8000/78 playback freezing.
    By Paulo Roberto Elias in forum Blu-ray: BDP8000 Series
    Replies: 13
    Last Post: 06-02-2011, 12:14 PM

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •