Results 1 to 7 of 7
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 69, Level: 1
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 8.0%
    Achievements:
    New Achievement!7 days registered

    Join Date
    Mar 2014
    Posts
    5
    Points
    69
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Cannot activate TV subtitles

    I am having issues enabling subtitles on any TV program.

    - The SUBTITLES button on remote shows dialog window "Subtitles Off, On, Automatic". However in when with Subtitles set to On or Automatic no subtitles are displayed.
    - Also tried enabling "Universal Access" + "Hearing Impaired" with no luck

    Philips 47PFL6158K/12 running QF2EU-0.173.46.0 (Date published: 2014-02-10), DVB-C Provider Kabel Plus AT

    Anyone else have the issue? Any ideas how to resolve?
    Last edited by baracudaz; 03-05-2014 at 05:13 PM.

  2. #2
    New Member
    Points: 69, Level: 1
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 8.0%
    Achievements:
    New Achievement!7 days registered

    Join Date
    Mar 2014
    Posts
    5
    Points
    69
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Just to reiterate. My objective is to watch TV programs with Subtitles enabled. The subtitles should transmitted along with TV channel.

    Any ideas what might be wrong? User error perhaps?

  3. #3
    Moderator
    Points: 21,019, Level: 44
    Level completed: 30%, Points required for next Level: 631
    Overall activity: 0%
    Achievements:
    New Achievement!Overdrive10000 Experience Points1 year registered
    Philips - Ina's Avatar
    Join Date
    May 2013
    Posts
    3,177
    Points
    21,019
    Level
    44
    Thanks
    44
    Thanked 105 Times in 88 Posts
    Rep Power
    10
    Quote Originally Posted by baracudaz View Post
    I am having issues enabling subtitles on any TV program.

    - The SUBTITLES button on remote shows dialog window "Subtitles Off, On, Automatic". However in when with Subtitles set to On or Automatic no subtitles are displayed.
    - Also tried enabling "Universal Access" + "Hearing Impaired" with no luck

    Philips 47PFL6158K/12 running QF2EU-0.173.46.0 (Date published: 2014-02-10), Cable DVB-T

    Anyone else have the issue? Any ideas how to resolve?

    Hi baracudaz,

    Who is your broadcast provider (and country)?

    And is it Cable (DVB-C) or Terrestrial (DVB-T) signal you are receiving?

    If it's DVB-T and the channels are analogue, then the subtitles need to be enabled via TeleText (TextTV).

    For digital channels, please check the following:

    HOME > [Setup] > [Channel settings] > [Languages] > [Primary subtitles] or [Secondary subtitles]
    Ensure these are set to an appropriate language

    If this still does not help please try to change the subtitle language via the OPTIONS button.

    Best regards,
    Ina
    Forum Mod

  4. #4
    New Member
    Points: 69, Level: 1
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 8.0%
    Achievements:
    New Achievement!7 days registered

    Join Date
    Mar 2014
    Posts
    5
    Points
    69
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Ian,

    Thanks for stopping by and providing some suggestions.

    My provider is Kabel Plus in Austria. They are Cable (DVB-C) provider (TV, Internet, Phone)

    List of channels are here:
    http://www.kabelplus.at/Downloads/Dr...igital-NO.aspx

    I tuned the digital channels (DVB-C) only with quite a few of them being HD which is great btw.

    Anyway I have tried setting the languages both for audio and subtitles. Selecting audio language works great on for example on Euronews which offers (EN, DE, FR,..).

    However I had no luck with subtitles. I tried setting [Primary subtitles] and [Secondary subtitles].

    I can see channels offer subtitles OPTIONS button on Remote > [Status] : "Subtitle" displays "German". But subtitles don't show on screen. Which is completely bizarre.

    I also tried changing the subtitle language via the OPTIONS button. Again nothing is displayed.

    Any other suggestions?

  5. #5
    Moderator
    Points: 21,019, Level: 44
    Level completed: 30%, Points required for next Level: 631
    Overall activity: 0%
    Achievements:
    New Achievement!Overdrive10000 Experience Points1 year registered
    Philips - Ina's Avatar
    Join Date
    May 2013
    Posts
    3,177
    Points
    21,019
    Level
    44
    Thanks
    44
    Thanked 105 Times in 88 Posts
    Rep Power
    10
    Quote Originally Posted by baracudaz View Post
    Hi Ian,

    Thanks for stopping by and providing some suggestions.

    My provider is Kabel Plus in Austria. They are Cable (DVB-C) provider (TV, Internet, Phone)

    List of channels are here:
    http://www.kabelplus.at/Downloads/Dr...igital-NO.aspx

    I tuned the digital channels (DVB-C) only with quite a few of them being HD which is great btw.

    Anyway I have tried setting the languages both for audio and subtitles. Selecting audio language works great on for example on Euronews which offers (EN, DE, FR,..).

    However I had no luck with subtitles. I tried setting [Primary subtitles] and [Secondary subtitles].

    I can see channels offer subtitles OPTIONS button on Remote > [Status] : "Subtitle" displays "German". But subtitles don't show on screen. Which is completely bizarre.

    I also tried changing the subtitle language via the OPTIONS button. Again nothing is displayed.

    Any other suggestions?

    Hi baracudaz,

    Your cable provider has not certified your TV for their service. Therefore this may be the reason why the subtitles from their broadcast doesn't work as expected.

    Unfortunately we cannot guarantee compatibility with standards that have not certified our TVs for their broadcast.

    In Austria the only cable (DVB-C) provider that has certified is UPC.

    Best regards,
    Ina
    Forum Mod

  6. #6
    New Member
    Points: 69, Level: 1
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 8.0%
    Achievements:
    New Achievement!7 days registered

    Join Date
    Mar 2014
    Posts
    5
    Points
    69
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for the response.

    Interesting I didn't know each TV needs to be officially certified for cable network. Now I wish I knew that before purchase I would certainly ask about it. Might be one of those things sales reps tend to hide from potential customers.

    What is the process of certification? Who has to request it Phillips or Cable provider? Can I ask for certification to be added in future FW releases?

    In a mean time I found workaround by using teletext subtitles (usually located at pages 149, 150, 777, 888 depending on chanel). Far from being ideal as teletext subtitles are using 8-bit computer era fonts and the font pixels are way too big for today's HD TV.

  7. #7
    Moderator
    Points: 21,019, Level: 44
    Level completed: 30%, Points required for next Level: 631
    Overall activity: 0%
    Achievements:
    New Achievement!Overdrive10000 Experience Points1 year registered
    Philips - Ina's Avatar
    Join Date
    May 2013
    Posts
    3,177
    Points
    21,019
    Level
    44
    Thanks
    44
    Thanked 105 Times in 88 Posts
    Rep Power
    10
    Quote Originally Posted by baracudaz View Post
    Thanks for the response.

    Interesting I didn't know each TV needs to be officially certified for cable network. Now I wish I knew that before purchase I would certainly ask about it. Might be one of those things sales reps tend to hide from potential customers.

    What is the process of certification? Who has to request it Phillips or Cable provider? Can I ask for certification to be added in future FW releases?

    In a mean time I found workaround by using teletext subtitles (usually located at pages 149, 150, 777, 888 depending on chanel). Far from being ideal as teletext subtitles are using 8-bit computer era fonts and the font pixels are way too big for today's HD TV.

    Hi baracudaz,

    Yes, TVs need to be certified for a provider's broadcast service (DVB-T, DVB-C and DVB-S) to ensure they can be assured to work with those providers.

    TVs are manufactured to be in line with the major providers of a certain area. It is an agreement made between the manufacturer's and the providers that initiates the certification on a business to business level.

    Certification has to be provided by the providers however and will not be delivered through software. The intricate details of the certification itself I can't get into unfortunately.

    The basic point is that it's down the providers to provide certification for various TV manufacturer's to ensure their customer's TVs are 100% compatible with their service.

    Some providers use slightly different broadcast standards than the larger providers and therefore we can't guarantee compatibility with these.

    Best regards,
    Ina
    Forum Mod

Similar Topics

  1. Can´s activate jointspace on phillips smart tv
    By Alex Marrufo in forum Smart TV: Software
    Replies: 0
    Last Post: 02-02-2014, 07:08 PM
  2. YouTube Activate Issue
    By Biz Diva in forum Blu-ray: BDP2000 & 3000 Series
    Replies: 4
    Last Post: 08-08-2013, 08:37 PM
  3. It wants me to activate before playing Audible Books...
    By will notgo in forum Sound: GoGear SA4-series (2012)
    Replies: 1
    Last Post: 07-15-2013, 09:27 AM
  4. To activate both the possibility of recording programs
    By enzo1 in forum Smart TV: Software
    Replies: 1
    Last Post: 01-21-2013, 04:46 PM
  5. activate jointspace for myremote
    By grobro in forum Apps: MyRemote App (for iOS)
    Replies: 1
    Last Post: 01-02-2013, 03:34 PM

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •