Results 1 to 5 of 5
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 25, Level: 1
    Level completed: 49%, Points required for next Level: 25
    Overall activity: 14.0%
    Achievements:
    New Achievement!

    Join Date
    Jun 2014
    Posts
    3
    Points
    25
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    bdp2100 hdmi no signal

    New bdp2100 works fine with analog video but hdmi shows start screen when powered on and then shows "no signal".
    Turned off "HDMI Deep Color" and must have tried every video setting imaginable with no luck.
    Tried the Home+7+3+1 trick too.
    TV is a Polaroid tdx02610b (26" TFT LCD, max resolution=1366x768, contrast ratio=800:1).

    Hoping I don't have to return the blueray player (I don't want to buy a new sofa to match the new curtains).
    Last edited by Jim Untershine; 06-23-2014 at 07:18 PM. Reason: additional TV specs

  2. #2
    Moderator
    Points: 7,040, Level: 24
    Level completed: 98%, Points required for next Level: 10
    Overall activity: 99.8%
    Achievements:
    New Achievement!3 months registeredOverdrive5000 Experience Points
    Philips - Rafal's Avatar
    Join Date
    Oct 2013
    Posts
    1,153
    Points
    7,040
    Level
    24
    Thanks
    27
    Thanked 44 Times in 41 Posts
    Rep Power
    10
    Hi Jim,

    Please reset the player to the factory settings and check if the problem gets resolved.

    Kind regards,
    Philips Moderation Team

  3. The Following User Says Thank You to Philips - Rafal For This Useful Post:

    Jim Untershine (06-25-2014)

  4. #3
    New Member
    Points: 25, Level: 1
    Level completed: 49%, Points required for next Level: 25
    Overall activity: 14.0%
    Achievements:
    New Achievement!

    Join Date
    Jun 2014
    Posts
    3
    Points
    25
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Although I had tried that previously - I tried it again with no luck (power off/on blueray gives Philips startup screen then startup background then "no signal").

    Just for giggles I hooked up the HDMI cable to my TV HDMI2 to verify the same scenario. Instead of power off/on blueray showing the Philips startup screen the TV shows "not support" and then "no signal". I then tried all the setting changes that I described previously to see if they had any effect with no avail.

  5. #4
    New Member
    Points: 25, Level: 1
    Level completed: 49%, Points required for next Level: 25
    Overall activity: 14.0%
    Achievements:
    New Achievement!

    Join Date
    Jun 2014
    Posts
    3
    Points
    25
    Level
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Problem solved!!!!
    The eSOURCE HDMI high speed 1440p cable from BigLots for $12 was the problem.
    The ONN HDMI high speed with Ethernet 1080p cable from Walmart for $13 solved the problem.

    "It's the little things - There is nothing bigger" (Vanilla Skies)

  6. #5
    Moderator
    Points: 7,040, Level: 24
    Level completed: 98%, Points required for next Level: 10
    Overall activity: 99.8%
    Achievements:
    New Achievement!3 months registeredOverdrive5000 Experience Points
    Philips - Rafal's Avatar
    Join Date
    Oct 2013
    Posts
    1,153
    Points
    7,040
    Level
    24
    Thanks
    27
    Thanked 44 Times in 41 Posts
    Rep Power
    10
    Hi Jim,

    I'm glad to hear you've solved the problem. Thanks for letting us know. It will benefit other forum users as well.

    Kind regards,
    Philips Moderation Team

Similar Topics

  1. HDMI - No Signal - 47 PFL 4007
    By cinujose in forum TV: Connectivity
    Replies: 2
    Last Post: 05-15-2014, 01:49 PM
  2. BDP5200/12 No more HDMI signal
    By flanker1 in forum Blu-ray: BDP5000 & 6000 Series
    Replies: 5
    Last Post: 07-15-2013, 07:41 AM
  3. no signal on HDMI
    By aoreich in forum Blu-ray: BDP8000 Series
    Replies: 6
    Last Post: 01-02-2013, 10:27 AM
  4. No Signal when connect BDP3200 to TV with HDMI
    By Jeroen123456 in forum Blu-ray: BDP2000 & 3000 Series
    Replies: 13
    Last Post: 03-25-2012, 09:27 PM
  5. 42pfl4606 'No Signal' on HDMI
    By Gallagher in forum TV: Connectivity
    Replies: 1
    Last Post: 12-08-2011, 10:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •