Results 1 to 3 of 3
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 1,110, Level: 8
    Level completed: 80%, Points required for next Level: 40
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Jul 2011
    Location
    Manchester
    Posts
    1
    Points
    1,110
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    philips 58pfl9955 choppy picture

    Hi All

    I have a philips 58" 21:9 3d tv, I have found that the picture can be a little choppy with artefacts especially on Apple TV 2 rented movies and on SKY HD?

    Has anyone else had this problem?

    Is it the source or the TV?

    Thanks

    Steve

  2. #2
    Diamond Member
    Points: 55,269, Level: 72
    Level completed: 82%, Points required for next Level: 281
    Overall activity: 100.0%
    Achievements:
    Recommendation Second ClassTagger First ClassOverdrive1000 Experience PointsNew Achievement!
    Awards:
    Posting Award

    Join Date
    Oct 2010
    Location
    Toengel's Philips Blog
    Posts
    6,185
    Points
    55,269
    Level
    72
    Thanks
    167
    Thanked 199 Times in 178 Posts
    Rep Power
    11
    Hi,

    did you installed the latest firmware 140.39?

    Toengel@Alex

  3. #3
    New Member
    Points: 1,088, Level: 8
    Level completed: 69%, Points required for next Level: 62
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Jul 2011
    Posts
    2
    Points
    1,088
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by jotaking View Post
    Hi All

    I have a philips 58" 21:9 3d tv, I have found that the picture can be a little choppy with artefacts especially on Apple TV 2 rented movies and on SKY HD?

    Has anyone else had this problem?

    Is it the source or the TV?

    Thanks

    Steve
    Hi, i have a different TV but i find for HD sources that if you turn off the Motion Plus or turn it to Cinema in the Smart Picture settings that this helps.

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •