Page 2 of 2 FirstFirst 12
Results 16 to 17 of 17
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #16
    Gold Member
    Points: 1,784, Level: 11
    Level completed: 78%, Points required for next Level: 66
    Overall activity: 33.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Jul 2011
    Location
    spain
    Posts
    286
    Points
    1,784
    Level
    11
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    None, your device needs to be checked since it looks like a defect

  2. #17
    New Member
    Points: 506, Level: 5
    Level completed: 56%, Points required for next Level: 44
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Apr 2012
    Posts
    3
    Points
    506
    Level
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Pacman View Post
    None, your device needs to be checked since it looks like a defect
    The strange thing is that I changed my first GoGear SA018 at the store when I bought it. The new one is the same: this fact lets me think that I don't charge it well..

    I also talked to the chat service and they told me to let it charge 12 hours because when the LED turns green has reached 40% charge: I'll try but I'm not sure..

Page 2 of 2 FirstFirst 12

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •