Results 1 to 5 of 5
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 1,029, Level: 8
    Level completed: 40%, Points required for next Level: 121
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Aug 2011
    Location
    Stockholm/Sweden
    Posts
    2
    Points
    1,029
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Unhappy MCD908 sound dead

    This is the Micro Theater with pre-amp tubes. A while ago it developed a hiss in one of the channels and more recently that's all I get, just hissing. I suspect an issue with the pre-amps, but does anyone else have this problem? Where can I find tubes, I can't even find any reference to what type it uses.

    Thanks,
    Krister

  2. #2
    Diamond Member
    Points: 65,618, Level: 79
    Level completed: 48%, Points required for next Level: 832
    Overall activity: 99.8%
    Achievements:
    Recommendation Second ClassTagger First ClassOverdrive1000 Experience PointsNew Achievement!
    Awards:
    Posting Award

    Join Date
    Oct 2010
    Location
    Toengel's Philips Blog
    Posts
    6,581
    Points
    65,618
    Level
    79
    Thanks
    198
    Thanked 261 Times in 234 Posts
    Rep Power
    12
    Hi,

    did you try to call your local philips support?

    Toengel@Alex

  3. #3
    Philips - Gary
    Guest
    Does this happen constantly? If the issue happens regardless of what is being played then it may be a problem with the unit but we cannot provide advice on how to repair products on this forum.

    I would encourage you to contact your local support as they will be able to discuss the matter with you and provide advice on the local repair options should this be necessary.

    The Swedish support for these products can be reached on the number below:

    08-57 92 91 00

    Måndag till fredag (Monday - Friday) 09:00 - 18:00

  4. #4
    New Member
    Points: 1,029, Level: 8
    Level completed: 40%, Points required for next Level: 121
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Aug 2011
    Location
    Stockholm/Sweden
    Posts
    2
    Points
    1,029
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Unhappy

    The unit is out of warranty naturally and yes, it is silent regardless of input. It just hisses.
    Anyway, I think it's one of the pre-amp tubes but this being a consumer product there are no markings on them. Guess it'll end up on the scrap heap.

    Thanks anyway.

  5. #5
    Administrator
    Points: 8,926, Level: 28
    Level completed: 30%, Points required for next Level: 424
    Overall activity: 100.0%
    Achievements:
    New Achievement!Overdrive5000 Experience Points3 months registered
    Philips - Katerina's Avatar
    Join Date
    Jun 2015
    Posts
    3,845
    Points
    8,926
    Level
    28
    Thanks
    7
    Thanked 32 Times in 32 Posts
    Rep Power
    10
    Hello participants of the thread and forum members in general!

    Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

    Kind regards
    Philips – Katerina

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •