Page 2 of 2 FirstFirst 12
Results 16 to 29 of 29
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #16
    Bronze Member
    Points: 1,314, Level: 9
    Level completed: 82%, Points required for next Level: 36
    Overall activity: 0%
    Achievements:
    Recommendation Second Class1 year registeredTagger Second Class1000 Experience PointsNew Achievement!
    Awards:
    User with most referrers

    Join Date
    Sep 2011
    Location
    Netherlands
    Posts
    19
    Points
    1,314
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Update: streams streamed/recorded with hts-tvheadend are played fine, and not only once. for example files: 20.ts and rtvnh.ts ( see above ) are played with q5551-0.10.94.1 , only streams do have problem, that they jerk first 30 seconds when starting and then continue normally. Only after watching tv-streams through DLNA, switching back to TV-watch-mode results in image and audio jerking alot like if there is some serious distortion in the dvb-t signal, going to standby and back on, fixes the problem.

    streams/recording made by mumudvb are not playing ( file bla.ts ) not through DLNA and not through USB, screen stays black and reboot of tv is needed to get it back to TV-mode.

    I found another issue, when watching tv-stream for > 1 hour, tv goes in to standby by itself.
    information about file/stream is really not acceptable. Nothing is reported at all, even the total length is not reported, and it is not possible to switch audio streams.

  2. #17
    Silver Member
    Points: 1,640, Level: 11
    Level completed: 30%, Points required for next Level: 210
    Overall activity: 0%
    Achievements:
    1 year registered1 year registeredTagger Second Class1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Posts
    59
    Points
    1,640
    Level
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3
    I have a somewhat similar problem

    46PFL9705H/12 firmware 140.40 and MediaTomb

    It will play some .ts files and not others. All are MPEG2 TS When it comes across one it can't/won't play the TV sort of "hangs". When I then try to get out of the "DLNA channel" back to a regular TV channel the picture is just black. The channels change but no picture displays. I have to restart the TV to get a picture back.

    Very disappointed. This is a premium TV. I expected much better.

  3. #18
    Diamond Member
    Points: 47,536, Level: 67
    Level completed: 42%, Points required for next Level: 814
    Overall activity: 100.0%
    Achievements:
    Recommendation Second ClassTagger First ClassOverdrive1000 Experience Points25000 Experience Points
    Awards:
    Posting Award

    Join Date
    Oct 2010
    Posts
    5,696
    Points
    47,536
    Level
    67
    Thanks
    112
    Thanked 118 Times in 105 Posts
    Rep Power
    9
    Hi,

    you can try the new firmware 140.44...

    Toengel@Alex

  4. #19
    Silver Member
    Points: 1,640, Level: 11
    Level completed: 30%, Points required for next Level: 210
    Overall activity: 0%
    Achievements:
    1 year registered1 year registeredTagger Second Class1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Posts
    59
    Points
    1,640
    Level
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3
    I've updated to firmware 140.44 and the problem still happens.

  5. #20
    Bronze Member
    Points: 1,314, Level: 9
    Level completed: 82%, Points required for next Level: 36
    Overall activity: 0%
    Achievements:
    Recommendation Second Class1 year registeredTagger Second Class1000 Experience PointsNew Achievement!
    Awards:
    User with most referrers

    Join Date
    Sep 2011
    Location
    Netherlands
    Posts
    19
    Points
    1,314
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    another thing, when watching TV ( internal dvb-t receiver but also through dlna) , tv goes to standby by itself after approx 1 hour of watching.

  6. #21
    Bronze Member
    Points: 773, Level: 7
    Level completed: 12%, Points required for next Level: 177
    Overall activity: 0%
    Achievements:
    3 months registeredTagger Second Class500 Experience PointsNew Achievement!

    Join Date
    Apr 2012
    Location
    Morocco
    Posts
    15
    Points
    773
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by none1234 View Post
    another thing, when watching TV ( internal dvb-t receiver but also through dlna) , tv goes to standby by itself after approx 1 hour of watching.
    Hi none1234,

    I'm about to buy a 46PFL8606 and I'm aiming for a similar setup to yours. I just wanted to confirm what you are doing : are you publishing the live satellite stream URLs using mediatomb and navigating using the philips TV DLNA client through the "channels" so that when you choose one, the TV starts picking up the live stream from your linux satellite box?

    I want to do the same using a Dreambox 500HD running mediatomb to publish the channels/services streaming URLs and be able to navigate through them and start streaming from TV. However I'm worried how the TV behaves for live streams comparing to recorded .ts files, because recorded files are streamed by mediatomb itself, while live streams are streamed by the dreambox and only their links published by mediatomb...

    What does the streaming links you publish using mediatomb look like? or do you publish m3u file or a stream file on your box?

    Thanks for your help, it will help me decide to go for this TV set!
    Last edited by soussef24; 04-23-2012 at 11:39 AM.

  7. #22
    Bronze Member
    Points: 1,314, Level: 9
    Level completed: 82%, Points required for next Level: 36
    Overall activity: 0%
    Achievements:
    Recommendation Second Class1 year registeredTagger Second Class1000 Experience PointsNew Achievement!
    Awards:
    User with most referrers

    Join Date
    Sep 2011
    Location
    Netherlands
    Posts
    19
    Points
    1,314
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    hi,

    I gave up on philips, I am using it as monitor/screen. No smart tv for me anymore, it is laggy, and outdated. before each stream starts there is 'buffering' time of 20 to 30 seconds, where the image
    and the sound are jerking/stoutering and TV also sometimes disconnects by itself , or goes in to standby.
    So I can not help with that. So what I did is this: every stream needs to be added one by one to the mediatomb, and needs to have mime type: video/Mp2T

    for tvheadend an External Link (url) would look like that:

    http://192.168.XXX.XXX:9981/stream/channelid/X

    Protocol: http-get
    Class: object.item.videoitem

    have no experience with enigma.

    and also tvheadend now has problems, it has not been updated for 2 years now, and because
    the dvb driver in the kernel has evolved and tvheadend has not, there is a problem with
    control of diseq switches, usually position 3 and 4 are not working well.

  8. #23
    Bronze Member
    Points: 773, Level: 7
    Level completed: 12%, Points required for next Level: 177
    Overall activity: 0%
    Achievements:
    3 months registeredTagger Second Class500 Experience PointsNew Achievement!

    Join Date
    Apr 2012
    Location
    Morocco
    Posts
    15
    Points
    773
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by none1234 View Post
    hi,

    I gave up on philips, I am using it as monitor/screen. No smart tv for me anymore, it is laggy, and outdated. before each stream starts there is 'buffering' time of 20 to 30 seconds, where the image
    and the sound are jerking/stoutering and TV also sometimes disconnects by itself , or goes in to standby.
    So I can not help with that. So what I did is this: every stream needs to be added one by one to the mediatomb, and needs to have mime type: video/Mp2T

    for tvheadend an External Link (url) would look like that:

    http://192.168.XXX.XXX:9981/stream/channelid/X

    Protocol: http-get
    Class: object.item.videoitem

    have no experience with enigma.

    and also tvheadend now has problems, it has not been updated for 2 years now, and because
    the dvb driver in the kernel has evolved and tvheadend has not, there is a problem with
    control of diseq switches, usually position 3 and 4 are not working well.
    Thanks for your reply none1234. Knowing that no "smartTV" is perfect and that Philips has the best value/price ratio where I live, I just bought a 46PFL8606 yesterday...

    So now I'm able to test the streaming setup. As I said before I'm using a Dreambox (it's a linux set-top-box), so the streaming link looks like :

    http://192.168.1.10:8001/1:0:19:232A...:C00000:0:0:0:

    So I did just like you, and added this link as an external URL in the mediatomb server running on the Dreambox with the same settings and mimetype you suggested. The uPnP server shows on the TV, with the expected folders and content.

    When I select a channel, the TV goes full black screen with a "Play" icon, but then returns back to the DLNA browsing menu.

    I also noticed that changing the mime type to "video/mpegLNA.ORG_PN=MPEG_PS_PAL" changes the TV behavior which keeps the full black screen and behaves like if it was playing but without image or sound. I know this mimetype is not the right one because what I have is a TS stream but I also tried the "video/vnd.dlna.mpeg-ttsLNA.ORG_PN=AVC_TS_HD_EU_ISO" which seems correct to me since I'm trying to stream H.264 channels, but then the TV behaves just like with the "video/Mp2T"...

    I'm lost because I can't even reproduce what you did...

    Any hints?

  9. #24
    Bronze Member
    Points: 773, Level: 7
    Level completed: 12%, Points required for next Level: 177
    Overall activity: 0%
    Achievements:
    3 months registeredTagger Second Class500 Experience PointsNew Achievement!

    Join Date
    Apr 2012
    Location
    Morocco
    Posts
    15
    Points
    773
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I redid the test using the "video/mpeg: DLNA.ORG_PN=MPEG_PS_PAL" and the TV is actually streaming because I see two hints on that :

    - A red LED indicating streaming blinks on the Dreambox : to the streaming actually started for sure.

    - When I click "info" on the remote control I can see that the timer moved from 00:00 however it seems to be very late compared to actual time when streaming started.

    I don't understand why the screen is black and no sound... Maybe the mime type causes the TV to use an inadequate codec. But what would be the right mime type?

  10. #25
    Bronze Member
    Points: 1,314, Level: 9
    Level completed: 82%, Points required for next Level: 36
    Overall activity: 0%
    Achievements:
    Recommendation Second Class1 year registeredTagger Second Class1000 Experience PointsNew Achievement!
    Awards:
    User with most referrers

    Join Date
    Sep 2011
    Location
    Netherlands
    Posts
    19
    Points
    1,314
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    yes I expected something like that, I am not sure if TV usses the full mime type, like: "video/mpeg: DLNA.ORG_PN=MPEG_PS_PAL" or it just looks for first part: "video/mpeg" , I expect it only uses the first part.

    and I can remember it also happend to me when I was trying different mime types. I am affraid that only trial and error can help you find out the right mime type.

    and you say that u are streaming H.264 channels, well I have no experience with that. I could however stream HD channel (zdfHD) from Astra 19, but that one is mpeg2.

    For H.264 channels you would probably need a different mime type.

    but for testing purposes I would suggest starting with SD, channels in Mpeg2-ts format.

    One thing to keep in mind , is that black screen can also occur on a stream or file that was playing perfectly before. But because the 'decoding hardware' for some reason has stopped functioning it would give you black screen. And to fix that you would need to reboot the TV. ( poweroff/unplug from power outlet, and not the standby button on the remote)

    so first, make sure dreambox is delivering Mpeg2-ts stream, test it with VLC-player or Mplayer. than use video/Mp2T as mime type. then reboot TV to be sure. start streaming, and indeed keep an eye on the lights on the network-switch or dreambox Lan-led or ifconfig in the console of dreambox, to be sure that something is being streamed and received by TV.

  11. #26
    Bronze Member
    Points: 1,314, Level: 9
    Level completed: 82%, Points required for next Level: 36
    Overall activity: 0%
    Achievements:
    Recommendation Second Class1 year registeredTagger Second Class1000 Experience PointsNew Achievement!
    Awards:
    User with most referrers

    Join Date
    Sep 2011
    Location
    Netherlands
    Posts
    19
    Points
    1,314
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    zdfHD is actually Mpeg4 , so I am not sure why it worked or maybe the format has been changed.

  12. #27
    Bronze Member
    Points: 1,314, Level: 9
    Level completed: 82%, Points required for next Level: 36
    Overall activity: 0%
    Achievements:
    Recommendation Second Class1 year registeredTagger Second Class1000 Experience PointsNew Achievement!
    Awards:
    User with most referrers

    Join Date
    Sep 2011
    Location
    Netherlands
    Posts
    19
    Points
    1,314
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    oh, there is also comercial DLNA server that claims that it supports streaming on philips TV's , maybe it could help you out finding out the right mimetype etc: Mezzmo

  13. #28
    Bronze Member
    Points: 1,314, Level: 9
    Level completed: 82%, Points required for next Level: 36
    Overall activity: 0%
    Achievements:
    Recommendation Second Class1 year registeredTagger Second Class1000 Experience PointsNew Achievement!
    Awards:
    User with most referrers

    Join Date
    Sep 2011
    Location
    Netherlands
    Posts
    19
    Points
    1,314
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

  14. #29
    Bronze Member
    Points: 773, Level: 7
    Level completed: 12%, Points required for next Level: 177
    Overall activity: 0%
    Achievements:
    3 months registeredTagger Second Class500 Experience PointsNew Achievement!

    Join Date
    Apr 2012
    Location
    Morocco
    Posts
    15
    Points
    773
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for your support.

    I used uPnP Inspector (a small software found on the internet), to try to determine what mimetype the Philips TV is expecting from the DLNA server. And got this list :

    http-get:*:audio/mpegLNA.ORG_PN=MP3,
    http-get:*:audio/L16;rate=44100;channels=2LNA.ORG_PN=LPCM,
    http-get:*:audio/L16;rate=44100;channels=1LNA.ORG_PN=LPCM,
    http-get:*:audio/L16;rate=48000;channels=2LNA.ORG_PN=LPCM,
    http-get:*:audio/L16;rate=48000;channels=1LNA.ORG_PN=LPCM,
    http-get:*:image/jpegLNA.ORG_PN=JPEG_SM,
    http-get:*:image/jpegLNA.ORG_PN=JPEG_MED,
    http-get:*:image/jpegLNA.ORG_PN=JPEG_LRG,
    http-get:*:image/jpegLNA.ORG_PN=JPEG_SM_ICO,
    http-get:*:image/jpegLNA.ORG_PN=JPEG_LRG_ICO,
    http-get:*:image/jpegLNA.ORG_PN=JPEG_TN,
    http-get:*:video/mpegLNA.ORG_PN=MPEG_PS_NTSC,
    http-get:*:video/mpegLNA.ORG_PN=MPEG_PS_PAL,
    http-get:*:video/vnd.dlna.mpeg-ttsLNA.ORG_PN=MPEG_TS_SD_EU,
    http-get:*:video/mpegLNA.ORG_PN=MPEG_TS_SD_EU_ISO,
    http-get:*:video/vnd.dlna.mpeg-ttsLNA.ORG_PN=MPEG_TS_SD_EU_T,
    http-get:*:audio/x-ms-asf:*,
    http-get:*:audio/wav:*,
    http-get:*:audio/x-ms-wma:*,
    http-get:*:audio/vnd.dlna.adts:*,
    http-get:*:audio/mp4:*,
    http-get:*:video/x-matroska:*,
    http-get:*:video/x-ms-asf:*,
    http-get:*:video/x-ms-asf-plugin:*,
    http-get:*:video/mpeg4:*,
    http-get:*:video/avi:*,
    http-get:*:video/x-ms-avi:*,
    http-get:*:video/msvideo:*,
    http-get:*:video/x-msvideo:*,
    http-get:*:video/h264:*,
    http-get:*:video/x-ms-wmv:*

    I'm still unable to play any stream from the STB. I tried SD channels which are normally mpeg2 (verified using VLC) and used the "video/mpeg" and the other MPEG_TS mimetypes listed above with no luck : the screen stays black while streaming starts for "video/mpeg", and the TV goes back to DLNA menu for the others...

Page 2 of 2 FirstFirst 12

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •