Results 1 to 5 of 5
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 982, Level: 8
    Level completed: 16%, Points required for next Level: 168
    Overall activity: 0%
    Achievements:
    1 year registered500 Experience PointsNew Achievement!

    Join Date
    Sep 2011
    Location
    Finland
    Posts
    2
    Points
    982
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    No DVD voice track via analog stereo out

    I have a new BDP7600/12 connected directly to stereo active speakers via the analog 2-channel outputs.

    For the first week or two, the unit worked fine with both DVDs and Blu-ray discs. However, suddenly a strange problem started with DVDs. The voice audo tracks can not be heard! The sound effect track is heard perfectly, but the voice is inaudible regardless of which language is chosen. The voice audio works fine for movie previews at the beginning of a DVD, but probably because there is no separate voice track. I have tried playing with all the audio settings, and the problem occurs for both DTS and Dolby.

    Any ideas? I have not been able to test yet if the same problem occurs for Blu-ray discs...

    Also as far as I can tell this has the latest firmware version.

    Thanks,
    Zach

  2. #2
    Diamond Member
    Points: 51,912, Level: 70
    Level completed: 55%, Points required for next Level: 638
    Overall activity: 100.0%
    Achievements:
    Recommendation Second ClassTagger First ClassOverdrive1000 Experience PointsNew Achievement!
    Awards:
    Posting Award

    Join Date
    Oct 2010
    Posts
    6,059
    Points
    51,912
    Level
    70
    Thanks
    157
    Thanked 176 Times in 157 Posts
    Rep Power
    10
    Hi,

    hmm - you should try to unplug your device from the power cord. Also try to load factory defaults and configure your BDP again...

    Toengel@Alex

  3. #3
    New Member
    Points: 982, Level: 8
    Level completed: 16%, Points required for next Level: 168
    Overall activity: 0%
    Achievements:
    1 year registered500 Experience PointsNew Achievement!

    Join Date
    Sep 2011
    Location
    Finland
    Posts
    2
    Points
    982
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Found and fixed the problem.

    The Philips audio setup is not very well designed for using 2 speakers on the analogue outputs. There is only an audio setting for "2 & 5.1 Channel". In order for 2 channel to actually work for 5.1 audio tracks, you must manually turn off the other surround speakers in the speaker settings. I would recommend that Philips separates the 2 channel and 5.1 channel setting in the menu, to avoid this problem.

    I finally noticed this when I found a DVD with both Dolby Stereo and Dolby 5.1 voice tracks. The Stereo worked fine, whereas the 5.1 had no voice, only sound. What happens, is that the voice is on the center channel for Dolby and DTS 5.1. So when the center and other un-used channels are turned off in the settings, the voice is redirected to the L/R outputs.

    Another note to Philips. Please don't have the default HDMI settings set to HDMI Deep Color and 3D turned on. At least my Optoma HD-20 is not able to function with these settings, and you need to use a composite cable to disable these in order to get the HDMI working.

    Thanks,
    Zach

  4. #4
    Moderator
    Points: 10,990, Level: 31
    Level completed: 63%, Points required for next Level: 260
    Overall activity: 16.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!10000 Experience Points
    Philips - Remko's Avatar
    Join Date
    Jun 2011
    Posts
    555
    Points
    10,990
    Level
    31
    Thanks
    0
    Thanked 5 Times in 2 Posts
    Rep Power
    10
    Hi zdshelby,

    Thanks for the suggestions given. To improve our products further, we are interested to know more about the customer behavior. Can you help answering the below questions?

    · Did you connect to the correct stereo analog output ? The connectors are labeled “2 CH / Surround Rear”

    · The default 3D and Deep Color setting should be on AUTO. Can you confirm if you set the player to AUTO or ON for Deep Color mode ? For 3D, there is no separate ON mode.


    Your feedback are key for our future product development. Hope we can hear from you soon. Thank you.

  5. #5
    Diamond Member
    Points: 51,912, Level: 70
    Level completed: 55%, Points required for next Level: 638
    Overall activity: 100.0%
    Achievements:
    Recommendation Second ClassTagger First ClassOverdrive1000 Experience PointsNew Achievement!
    Awards:
    Posting Award

    Join Date
    Oct 2010
    Posts
    6,059
    Points
    51,912
    Level
    70
    Thanks
    157
    Thanked 176 Times in 157 Posts
    Rep Power
    10
    Hi zdshelby,

    did you tried the test as Remko suggested?

    - can you recheck your analog connections?
    - can you recheck the settings?

    Toengel@Alex

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •