Hi,

I have just bought a new 32" LCD Philips TV model 32PFL4505D/F7.

I already have another 32" LCD from Philips, one year older (720, instead of 1080).

The new TV has 2 annoying things and I do not know if it is expected or I should return it as it is still under Amazon return time.



1.
Cable Box (Verizon Fios) connected via HDMI to the TV. It does not matter HDMI 1 or 2... same results.
I turn on my cable box, and leave it on for this test.
I turn on the TV.
No signal.... 5 seconds... no signal 30 seconds... no signal....
I unplug and plug the HDMI cable... oh, now I get the signal.
I watch TV.
I turn OFF the TV.
Wait 5 seconds.
I turn ON the TV.
No signal again... 1 minute... no signal...
I turn OFF the TV.
Wait 5 seconds.
I turn ON the TV.
Signal is good after 5 seconds.
I watch TV.
I turn OFF the TV.
Wait 5 seconds.
I turn ON the TV.
No signal.... 1 minute ... no signal...
turn OFF the TV.
Wait 5 seconds.
I turn ON the TV.
Signal is good after 5 seconds.
I watch TV.


So, you get an idea... every other time the HDMI syncs with the box... but not every time as my other Philips TV does. (And I tried with the same box and the same cable).




2.- Minor problem.
The TV image is more greenish than my other TV. I try to adjust everything and... still more greenish. I think it is the black, that it tends to be a little greenish. If I turn down the brightness (energy sage mode ON or just turning down the brightness) the greenish seems to diminish... but what's the point of having an LED backed TV if you cannot put it bright... ok, you can, but the image is green-ish.




Soooooooooooooooo, any idea? Should I return it or this is what I have to expect for a 330$ TV?



Thanks,

Kind regards,
Fran