Hello!


Already trying for hours, but still not able to connect my XBOX360 to Philips PFL3606 Full HD 42" using HDMI cable.The strange thing is that yesterday trying to use S-video AV everything worked great and weirdly enough , connecting to HDMI cable everything worked as well. (using S-video AV cable still works) , but today I have tried everything , still no success.
I even found out the solution - HDMI puts the best settings by default , which my TV is not able to handle, that`s why I cant see any picture and get this "display mode is not supported" kind of thing. I found this solution...

Here’s a step by step guide:
1. Connect your 360 to your TV with the included composite (Yellow, Red, White) cable .
2. Ensure you’re running the new Xbox dashboard (Avatars support).
3. Ensure no profile auto-sign’s in at boot up.
4. Power off 360 and TV. Connect the HDMI cable between them.
5. Hold down the controller’s xBox button for 3 seconds to power on, and wait for about 20 seconds.
6. Press right on the (dpad) left analog stick 9 times, to navigate to the System Settings menu.
7. Press the A button 4 times. (This will go to System Settings, Console Settings, Display, HDTV settings.)
8. Press up twice on the (dpad) left analog stick. Press A.
9. If no picture appears, wait 15 seconds, Press up again and press A. What you are doing is selecting lower display resolutions. Once you have a picture, you can try other higher resolutions, if you want, and it will revert back if you don’t confirm it is ok. The 360 will remember the setting you finalize.

But the next weird problem is that when I turn on my Xbox360 using HDMI cable , most of the times controller just keeps flashing, but not able to connect to Xbox, I don`t know whats the problem. That`s why I`m not even able to get to this "STEP by STEP" guide, to try to change HDTV settings. There have been some times , when somehow my controller connects to XBOX360, but it still doesnt work, when I follow this "Step by Step" guide. It seems I have tried everything..Still nothing..

Any help?
Thank you!