Page 2 of 11 FirstFirst 1234 ... LastLast
Results 16 to 30 of 165
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #16
    Diamond Member
    Points: 4,685, Level: 20
    Level completed: 9%, Points required for next Level: 365
    Overall activity: 25.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!
    Awards:
    Frequent Poster

    Join Date
    Jul 2010
    Posts
    1,083
    Points
    4,685
    Level
    20
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    6
    I'd say a bad/good rate of 60%/40%, till now.
    that s not good... anyone in Brazil experience the same?
    Last edited by kwinnie; 11-30-2011 at 07:53 AM.

  2. #17
    Moderator
    Points: 10,990, Level: 31
    Level completed: 63%, Points required for next Level: 260
    Overall activity: 16.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!10000 Experience Points
    Philips - Remko's Avatar
    Join Date
    Jun 2011
    Posts
    555
    Points
    10,990
    Level
    31
    Thanks
    0
    Thanked 5 Times in 2 Posts
    Rep Power
    10
    Hi All,

    Thanks for your feedback.

    We would like to give you a brief update that the development team is now looking into 1) Harry Porter disc issue and 2) Brazilian disc issue.

    For the other disc playability issue, we will follow our normal way of work- will order and verify them. We will update you on the progress.

    Thank you,
    Philips Moderation team
    Last edited by Philips - QK; 12-01-2011 at 02:50 AM.
    Forum Mod

  3. #18
    Bronze Member
    Points: 923, Level: 7
    Level completed: 87%, Points required for next Level: 27
    Overall activity: 0%
    Achievements:
    1 year registered500 Experience PointsNew Achievement!

    Join Date
    Nov 2011
    Posts
    15
    Points
    923
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Also here in Italy problem with Harry Potter and Deathly Hallows part 2
    Image stutters sometimes. Sound OK

    New disc, no dust/scratches. Other discs seem to be OK.

    BDP 9500/12
    firmware 1.09

  4. #19
    New Member
    Points: 872, Level: 7
    Level completed: 61%, Points required for next Level: 78
    Overall activity: 0%
    Achievements:
    1 year registered500 Experience PointsNew Achievement!

    Join Date
    Nov 2011
    Location
    Denmark
    Posts
    4
    Points
    872
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    BDP2850/12 Stutter on Twilight film 1080p 24

    Brand new player
    Device: BDP2850/12
    Software: 1.54 (latest)


    Heavy Stutter every few seconds from right beginning of films. Tried 4 films and 3 are bad.
    Considering returning device.

    Tested in shop:
    - with different high grade cable - no changes
    - in different player (LG) - plays OK

    Bad performance on:
    Titles (rental copies):

    Twilight New Moon
    EAN 705410681256

    Twilight Eclipse
    EAN 705410681881

    Title 22 Bullets (Jean Reno) produced by Luc Besson
    Don't have EAN at the time of writing this.

    Playing OK:
    Eat Pray Love (w Julia Roberts)
    Don't have EAN at the time of writing this.


    To Philips - please provide new software quisckly or the device goes back.

  5. #20
    New Member
    Points: 1,290, Level: 9
    Level completed: 70%, Points required for next Level: 60
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Location
    Brasil
    Posts
    2
    Points
    1,290
    Level
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by kwinnie View Post
    that s not good... anyone in Brazil experience the same?
    My BDP8000 is the Brazilian (Device: BDP8000/78 SW version: V1.60). Watching Harry Potter 7.2, the same thing happened to me too. In certain scenes in the film is a "delay" or "jump" in the image. I changed the default setting for the player and the problem persisted. I thought the problem was the disc that is American (UPC: 883929140886), however, by placing the disc, this time the Brazilian (EAN 7892110075442), the problem still exists. It is the first time it happened. No problem with other movies. Thanks!

  6. #21
    Diamond Member
    Points: 4,685, Level: 20
    Level completed: 9%, Points required for next Level: 365
    Overall activity: 25.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!
    Awards:
    Frequent Poster

    Join Date
    Jul 2010
    Posts
    1,083
    Points
    4,685
    Level
    20
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    6
    hello GTomaz, the harry porter disc if you are referring to the deathly hollows, there s stutter issue confirmed.
    philips said they will work on this ...

  7. #22
    New Member
    Points: 1,051, Level: 8
    Level completed: 51%, Points required for next Level: 99
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Jul 2011
    Posts
    4
    Points
    1,051
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    BDP 3200/05 sw1.42

    used to play but no longer plays

    Inception EAN 5051892011969

    The Ultimate Bourne Collection EAN 5050582710212 - None of the three films!

    Avatar Collectors edition EAN 5039036045544

    The Expendables EAN 5060223760025

    All unknown disc errors, sounds like a dot matrix printer when it tries to read the discs.Machine is less than a year old! Since the last s/w update pretty much none of my blue rays are now working!

  8. #23
    Diamond Member
    Points: 4,685, Level: 20
    Level completed: 9%, Points required for next Level: 365
    Overall activity: 25.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!
    Awards:
    Frequent Poster

    Join Date
    Jul 2010
    Posts
    1,083
    Points
    4,685
    Level
    20
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    6
    hi ItsYerDa!

    if all your disc cant be played, or it shows "unknown disc" issue,
    it's probably a loader problem... i think you have to go to service to see if you hv to exchange that part...

    your player still under warranty?

  9. #24
    New Member
    Points: 1,051, Level: 8
    Level completed: 51%, Points required for next Level: 99
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Jul 2011
    Posts
    4
    Points
    1,051
    Level
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I don't think its the disc loader as Shutter Island, Wonders of the Universe and Pacific boxset are still playing.
    Also AVCHD discs i've burned play fine as do DVD's, i wish i could revert to the previous firmware as everything was fine with version 1.32.
    Its a bit depressing that i cant play the majority of blue rays i've bought!

  10. #25
    Platinum Member
    Points: 2,996, Level: 15
    Level completed: 82%, Points required for next Level: 54
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsOverdriveNew Achievement!
    Awards:
    Discussion Ender
    Oscar's Avatar
    Join Date
    Feb 2011
    Posts
    722
    Points
    2,996
    Level
    15
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    4
    So you say they worked beofe but after doing an upgrade these discs do not work anymore??

  11. #26
    New Member
    Points: 759, Level: 7
    Level completed: 5%, Points required for next Level: 191
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Dec 2011
    Location
    London/UK
    Posts
    2
    Points
    759
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Title Blu-ray disc: Star Wars The Complete Saga
    EAN: 039036048453
    Device: BDP7500/12
    SW version: V1.02

    Hi,

    I just bought my first Blu-Ray player this Christmas for the family - a Philips BDP7500BL/05 - and a set of Blu-Rays (Stars Wars Complete Saga, Star Wars Clone Wars, Harry Potter Collection and the Cars & Cars 2 box set). We had no problems with Cars, but intermittent problems with Cars 2 ( stopped a couple of times and we had to take out the disk and start again).

    We just tried to watch Star Wars Phantom Menace and the disk doesn't load - just a blank screen. After several minutes there is still nothing and I have to turn off the player to get it to eject the disk. I've tried all 9 disks from the set and none of them load. Looking at this forum, there seems to be some problem with the Philips players and the star wars disks.

    I've checked the firmware and tried the network update and the device tells me I have the latest version - v1.02 - i haven't tried the USB option yet. I've also reset the unit and it still has the same problem.

    Cars 1 and Clone Wars plays fine, as does Harry Potter 3.

    Is there a fix for this? or a customised set of disks? or should I get a different blu-ray player?

    Edit 1:
    I should add that all the disk and the player were bought in the UK through Zavvi.com and Pixmania.com

    Edit 2: I found the firmware update to v1.10 on the support page and have applied that upgrade via USB, so the player now shows software version 1.10. i still get the same problem - just a blank screen, sometimes with a big play symbol and sometimes with the warning text about blu-ray playback but nothing else - it just freezes & then I have to pull the power, restart and eject the disc.


    Thanks,
    Amo
    Last edited by amokhera; 12-26-2011 at 08:17 PM. Reason: additional information

  12. #27
    New Member
    Points: 754, Level: 7
    Level completed: 2%, Points required for next Level: 196
    Overall activity: 80.0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Dec 2011
    Location
    São Carlos, SP / Brazil
    Posts
    1
    Points
    754
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have hard difficulties to run Avatar Extended Edition Brazilian Blu-ray EAN 7898512975731 in my BDP3100 since the discs menus aren't available.

  13. #28
    New Member
    Points: 759, Level: 7
    Level completed: 5%, Points required for next Level: 191
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Dec 2011
    Location
    London/UK
    Posts
    2
    Points
    759
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I managed to fix my problem with Star Wars. I went to John Lewis and bought a Sony BDP-S570 instead.... As its on old model they did it for £99 which is only £10 more than I paid for the Philips.... Hopefully I can now recoup some of my money by selling this on eBay.

    It's a shame, I've had a Philips DVD player for the last few years and it's been rock solid...

    Amo

  14. #29
    New Member
    Points: 763, Level: 7
    Level completed: 7%, Points required for next Level: 187
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Dec 2011
    Location
    france
    Posts
    1
    Points
    763
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    star war saga won't play on bdp7500SL...but you already know.

    Hi,
    I have exactly the same problem as amokhera, no disks from star wars saga could be read on my player.

    BDP Model: Philips Blu-ray Disc-Player BDP7500SL

    Firmware Version: V1.12

    Its the french blu ray collection.

    I saw that many other users have reported the same problem since this pack was released, 4 month ago!

    Is there an unfixable issue?? it seems like...

    thanks for your answer.

  15. #30
    New Member
    Points: 838, Level: 7
    Level completed: 44%, Points required for next Level: 112
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Dec 2011
    Location
    germany
    Posts
    3
    Points
    838
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have the BDP3280/12 blue ray player, which sometimes hangs shortly after starting a movie from the "Star Wars - The complete Saga" blue ray collection.
    EAN: 4010232053084
    It hangs in the movie (so after reaching the menu, selecting to play the movie).
    I then have to pull the power cord, as the player does neither react to remote control, nor the keys on the device.
    After this cold boot I can play the movie without a problem, so it does not hang at the same position again.
    So far this happened on Episode 2 and Episode 4 disk.
    There seems to be no newer firmware available.
    Model Number: BDP3280/12, SN: GS1A1136038714
    I do not have an USB stick plugged in into the player

Page 2 of 11 FirstFirst 1234 ... LastLast

Similar Topics

  1. Wish for the next year blu-ray player models
    By Freddo in forum Blu-ray: Share Your Wish List and Insights
    Replies: 4
    Last Post: 10-06-2011, 07:42 AM
  2. Startup behaviour of your blu ray player
    By rollufje in forum Blu-ray: Share Your Wish List and Insights
    Replies: 8
    Last Post: 08-09-2011, 07:24 PM
  3. Pause Blu-Ray over EasyLink does not work
    By cybernesto in forum Blu-ray: BDP5000 & 6000 Series
    Replies: 2
    Last Post: 07-30-2011, 09:02 AM
  4. BDP7500 mkII + The Expandables Blu Ray
    By pigmachine in forum Blu-ray: BDP7000 Series
    Replies: 3
    Last Post: 07-21-2011, 07:22 AM
  5. Sound of Blu Ray via Receiver corrupted
    By rldegier in forum Blu-ray: BDP7000 Series
    Replies: 3
    Last Post: 07-01-2011, 07:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •