Page 2 of 2 FirstFirst 12
Results 16 to 18 of 18
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #16
    New Member
    Points: 424, Level: 4
    Level completed: 74%, Points required for next Level: 26
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience PointsNew Achievement!

    Join Date
    Jun 2012
    Location
    Denmark
    Posts
    2
    Points
    424
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    MCi500

    I got absolutely no help from philips apart froma pointed finger in the direction of a workshop which cost 2700 Danish kroner. This was, luckily, sorted through my house insurance. I would not and will not buy any other philips product. Hope you other guys and girls find happier endings to your problems.
    Over and out

  2. #17
    New Member
    Points: 66, Level: 1
    Level completed: 16%, Points required for next Level: 84
    Overall activity: 0%
    Achievements:
    7 days registeredNew Achievement!

    Join Date
    Nov 2012
    Posts
    1
    Points
    66
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi All,
    there are normally two kind of problems I discoverd.
    1.) Unit is not switching on : This is a fault in the power supply. This has to be repaired on component level.

    2.) Unit is not booting correctly : This could be a problem with one of the drives defect. If you have basic
    skills you could try to open the unit and change the DVD Rom against another standard drive to
    check.

    Hopefully this helps to bring some of the units back to live ;-)

  3. #18
    Moderator
    Points: 4,937, Level: 20
    Level completed: 72%, Points required for next Level: 113
    Overall activity: 100.0%
    Achievements:
    New Achievement!31 days registeredOverdrive1000 Experience Points
    Awards:
    Frequent Poster
    Philips - Katerina's Avatar
    Join Date
    Jun 2015
    Posts
    2,327
    Points
    4,937
    Level
    20
    Thanks
    2
    Thanked 8 Times in 8 Posts
    Rep Power
    3
    Hello participants of the thread and forum members in general!

    Hopefully your issue was dealt with and you are no longer facing it. Since the thread has been silent for some time now, I will proceed by closing it. If you still have the same question about the same issue or any similar issues arise feel free to start a new thread or contact one of us moderators to open this thread again.

    Kind regards
    Philips – Katerina

Page 2 of 2 FirstFirst 12

Similar Topics

  1. WADM cannot see music on MCI500H
    By Midget in forum Sound: Streamium MCi series (MCi900| Mci8080| MCi730| MCi500| MCi298)
    Replies: 14
    Last Post: 02-05-2012, 01:18 PM
  2. Non-latin MP3-Tags on MCI500H
    By lucky in forum Sound: Streamium MCi series (MCi900| Mci8080| MCi730| MCi500| MCi298)
    Replies: 1
    Last Post: 11-28-2011, 10:59 AM
  3. BDP5200 "blocked" message?
    By boilerplate dan in forum Blu-ray: BDP5000 & 6000 Series
    Replies: 1
    Last Post: 09-30-2011, 08:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •