Hi all
my big problem is:
I have downloaded latest firmware from official site(42pfl7603d_12_fus_eng.zip,Version : 000.064.079.000) for my TV Philips 42PFL7603D/12!
I followed the steps exactly as suggested in the "Firmware Upgrade Readme File"!!
The TV set was rebooted and enter in to the firmware upgrade menu. The upgrade file has successfully uploaded from flash drive to TV set and has successfully validated. Then process has been frozen for 1 minute and then has written an "error Programming".
From this moment, when I take power off my TV set, it's back power on after 10 seconds and enter into the firmware upgrade menu again.
I tried again several times but I still get the same result!

can anyone help me return to old firmware version or upgrade the firmware to new one correctly?
my old firmware version on TV set is Q582E-0.64.30.5
New downloaded firmware version from official site is Q582E-0.64.79.0
If someone has solved this problem, please put all the details on the forum, including the brand of flash drive used.

Best regards, Adrian