TIP!
I observed that “WIDE CHANNEL” settings in the router can cause connectivity problems between TV and Router.

In case of connectivity problems, please check if your (modern, 802.11N enabled) router has an option for ‘Wide Channel’. If so, try to disable it.
Click image for larger version. 

Name:	Capture.JPG 
Views:	177 
Size:	98.4 KB 
ID:	752