Hi all,

On my 32PFL6606H I only have one USB port.

So in order to record broadcasts I connectec an USB hub (actually tried 2 different ones but more about that later.

I use the PTA01 dongle from Philips
The HD I use is a LaCie box (3.5'' SATA) to which I added a 500GB Western Digital 7200 rpm I had.

If I connect one of these devices to the TV everything is OK, but as soon as I connect the other things do not work:

1) If I have WiFi attached, then turn on the HD, the hub and the wifi dongle resets. Then it is not possible to go into the EPG anymore (the layout comes up, but as soon as the listing of program starts, the EPG quits without any message, and I am back on the channel I was on before entrering EPG)
2) If the HD is connected but not WiFi, I can timeshift properly no problem. But as soon as I add the WiFi, timeshift stops after 10 seconds or so. Also entering the EPG is not possible (same error as in 1)

I tried all this with both external powersource for the hub and only bus powered. I also switched the ports around in case there some hub ports were more advanced than others. But the main errors are still there.

So I see 2 different potential issues:
1) The USB hub is bugged. Not likely, I switched the Belkin 2.0 hub I was using into a brand new USB 3.0 (thinking the logic in a 3.0 is more advanced than 2.0) but the same issue happens
2) The HD or the Wifi are defect. At least the dongle works like it should and is brand new. But maybe it is the power management of the HD that is not good enough causing interference.

Any advice here? Not being able to record drives me crazy...

I am thinking about trying another HD but after that I really dont see a lot of options.

And I think I already spent too much time and money on getting out of the box functionality to work, so really need good advice here. (My LG TV and my Samsung Blueray HD was a lot less problematic and bug free...)

Or if someone can give me advice on what hub and (cheap) HD that they have been able use to get this to work.

BR