Results 1 to 4 of 4
  • Topic Tools
  • Display
  • Bookmark and Share

Hybrid View

  1. #1
    New Member
    Points: 754, Level: 7
    Level completed: 2%, Points required for next Level: 196
    Overall activity: 0%
    Achievements:
    3 months registeredTagger Second Class500 Experience PointsNew Achievement!

    Join Date
    Jan 2012
    Location
    Singapore
    Posts
    2
    Points
    754
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    42PFL5606S LED TV + Linux + NVIDIA = HDMI resolution wrong, but VGA quality good

    Hi there,

    I bought a very expensive HDMI cable to connect my 42PFL5606S LED TV to my PC, which is running a Linux Mint.

    The NVIDIA driver reports the "native resolution" of the TV as 1360x768, and not 1920x1080. Forcing the output to 1920x1080 looks genuinely awful. At 1360x768 the TV actually looks good, but hey, it's a HD screen, right?

    The problem is specific to HDMI: I tried a VGA cable instead, and that works fine at Full HD resolution.

    Moreover, using the same HDMI cable, my NVIDIA card read the correct resolution on my other Philips monitor (FWIW: a 227ELPH).

    I think the NVDIA-HDMI is somehow confused about what the screen can take. My xorg.conf has a section:

    Code:
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Philips 42PFL5606S"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    Can it be that the edid of my 42'' screen is just plain wrong and confusing the PC with what is possible?

    Can anyone help me (preferably without hacking xorg.conf)?

    Thanks!
    Erik

  2. #2
    New Member
    Points: 681, Level: 6
    Level completed: 66%, Points required for next Level: 69
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Jan 2012
    Posts
    3
    Points
    681
    Level
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Erik,

    [QUOTE=tweewo;24096]Hi there,

    My xorg.conf has a section:

    Code:
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "Philips 42PFL5606S"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    [/QUOTE=tweewo;24096]


    Try not specifying the Horizontal and Vertical sync values. Most modern Linux distro-s have a recent enough Xorg that is able to guess most of this by itself. If that fails look into the Xorg.0.log file (usually in /var/log) to see the EDID reasoning of Xorg...

    With kind regards,

    Jeroen

  3. #3
    New Member
    Points: 754, Level: 7
    Level completed: 2%, Points required for next Level: 196
    Overall activity: 0%
    Achievements:
    3 months registeredTagger Second Class500 Experience PointsNew Achievement!

    Join Date
    Jan 2012
    Location
    Singapore
    Posts
    2
    Points
    754
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks Jeroen! Unfortunately, removing syncs did not make a diff. The Xorg logging looks clean to me.

    Code:
    erik$ nvidia-settings -q all
    
    ...lotsastuff...
    
    Attribute 'FlatpanelNativeResolution' (erik:1[gpu:0]; display device: DFP-1): 1360,768.
        'FlatpanelNativeResolution' is a packed integer attribute.
        'FlatpanelNativeResolution' is a read-only attribute.
        'FlatpanelNativeResolution' is display device specific.
        'FlatpanelNativeResolution' can use the following target types: X Screen,
        GPU.
    
    ...more lotsastuff...
    I suspect the edid is simply wrong. I tried Option "UseEDID" "FALSE", but then it turned to 640x480. Urgh... 1992.

    Anyway, I read that there are yet many more problems with sound through NVIDIA-HDMI on Linux, so I have decided to give up for now. My VGA does full HD. Analog or digital I don't think I can spot the difference. Perhaps I'll try again with the next NVIDIA driver or with new Philips firmware.

    Thanks again, Jeroen for responding so fast!

    Cheers,
    Erik

  4. #4
    New Member
    Points: 681, Level: 6
    Level completed: 66%, Points required for next Level: 69
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Jan 2012
    Posts
    3
    Points
    681
    Level
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by tweewo View Post
    Thanks Jeroen! Unfortunately, removing syncs did not make a diff. The Xorg logging looks clean to me.
    You are right, looks like the EDID doesn't report the resolution right (I don't have that problem with my 32PFL7606 and G210)

    I suspect the edid is simply wrong. I tried Option "UseEDID" "FALSE", but then it turned to 640x480. Urgh... 1992.
    You could try adding something like " Option "metamodes" "1920x1080_60 +0+0" " to your Screen-section.


    Anyway, I read that there are yet many more problems with sound through NVIDIA-HDMI on Linux, so I have decided to give up for now. My VGA does full HD. Analog or digital I don't think I can spot the difference. Perhaps I'll try again with the next NVIDIA driver or with new Philips firmware.
    Had those issues as well (so I used S/PDIF for that. However I started using Openelec which has just about the latest versions of everything and to my suprise it only needed a "plughw:0,7" custom audio setting in XBMC to get it to work...

    Maybe it is a good idea for you to try liveUSB Openelec some time, just to make sure it is not some arcane configuration problem... You can get it easily on to a USB-stick using the instructions from here: http://www.openelec.tv/get-openelec

    Good luck!

    Jeroen

Similar Topics

  1. Replies: 61
    Last Post: 02-12-2013, 07:03 AM
  2. HDMI connection on 47'' LED 4000 series television
    By Maza in forum TV: Connectivity
    Replies: 8
    Last Post: 11-04-2011, 08:54 PM
  3. Philips PFL3606 Full HD 42" VGA better quality than HDMI
    By dogggg in forum TV: Connectivity
    Replies: 3
    Last Post: 11-02-2011, 10:15 PM
  4. TV won't show 1920x1080 resolution using HDMI
    By yshabi in forum TV: Connectivity
    Replies: 2
    Last Post: 08-31-2011, 07:17 AM
  5. My new TV 40PFL9705K ( Nvidia 3DTV Play )
    By dorenthe in forum TV: 3D
    Replies: 2
    Last Post: 08-02-2011, 07:35 PM

Tags for this Topic

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •