Wi-Fi Media Connect worked for about 2 weeks when we first got it ? (Yay!). Then, for no reason (no change in hardware/software, network config, etc.), I now get a Connection Error on the TV when attempting to project from my PC using the Media Connect software.

I have a 46PFL4706 TV. The TV has the latest firmware. The TV is connnected to my wireless network and is able to "Browse PC" as well as connect to Philips wirelessly for checking the firmware version, as well as use Net TV features.

When I attempt to project to the TV, I get the standard warning about my screen resolution too high, the TV shows a big white "play" triangle icon as though it's about to show my PC desktop, and then the TV shows a connection error. I am able to ping the TV from the PC.

I was on the phone for 2 hours with a philips customer service technician attempting to resolve the issue, to no avail.

The PC is a 2.4GH dual core, HP dv7 laptop with 6 GB of RAM, and Windows 7 64-bit. Firewall is norton 360. I use a belkin router (and yes, UPnP is enabled on the router).

I've tried
a) uninstall, reboot, reinstall
b) disable norton firewall
c) turn off tv, wait 5 minutes, try again
d) install SW on another, clean machine (it's never had wifi media connect), also windows 7 64-bit, 2.24 Gz dual core 2 gb of RAM, no firewall, etc. Exact same error.

I'm at a loss as to why Media Connect no longer works.

------ two to three weeks pass ----
Fast forward to last night. Just for laughs, I tried to project to the TV again. The HP laptop above (which if you're following this thread initially worked fine, then stopped working for no reason) was able to project to the TV once again. What in the heck changed? The second laptop we used to try and troubleshoot the HP was still unable to project. It gets same Network Connection error code starting with NE00...

Why is this connection so intermittent and always with the same meaningless error code? Are there no log files to identify why all other wi-fi functions are ok, like browsing the PC, but the Media Connect feature is unable to operate?

Please tell me what I can do (or tell me that you agree you are working on a more stable piece of networking software) so that I can rely on Media Connect to work each and every time I need it to. Right now, I feel like the software rolls the magic 8-ball to determine if it wants to work that day. No rhyme. No reason.