Page 1 of 2 12 LastLast
Results 1 to 15 of 28
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    Moderator
    Points: 10,990, Level: 31
    Level completed: 63%, Points required for next Level: 260
    Overall activity: 16.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!10000 Experience Points
    Philips - Remko's Avatar
    Join Date
    Jun 2011
    Posts
    555
    Points
    10,990
    Level
    31
    Thanks
    0
    Thanked 5 Times in 2 Posts
    Rep Power
    10

    BDP9600 Latest Firmware Upgrade (1.62) has been released

    Version: 1.62 is only released to BDP9600/12, /51, /93, /98

    Version: 1.62 includes the following changes:

    • Fixes the stuttering playback issues found on the Blu-ray disc Harry Potter and the Deathly Hallows: Part 2.

    The former firmware version includes the following changes:
    • Fixes the following issues: (1.61)
    o Speaker settings were lost after player went to standby.
    o Center speaker audio was missing when center speaker is set to OFF
    • Fixes the issues found on the following Blu-ray discs: (1.60)
    o HBO True Blood Season 3, unintended graphics in the Bonus feature menu Trueblood lines.
    o Sherlock Holmes, intermittent narration in Live screening feature.
    o Jumanji, unable to select subtitles from the Subtitle list.
    • Add on-screen keyboard in NetTV for easier and better navigation. (1.60)
    • Add Tuneln FM in NetTV. (1.60)
    • Fixes the following issues: (V1.56)
    o Volume setting for multi-channel analog audio output does not work (via Setup > Speaker Setup menu).
    o Audio distortion issue found on the certain audio CD’s when played back with Neo6 mode.
    o Not able to format 8GB SD cards for the Video-on-Demand feature.
    o Stuttering video on certain AVCHD discs.
    o Playback of Avatar 3D in 2D mode
    • Catch-up TV (via NetTV feature) is enabled for Netherlands. (V1.53)
    • Resolves an issue of video stuttering during disc playback while connected to a wireless network. (V1.53)
    • Improves the playability of Avatar Extended Collector’s Edition discs. (V1.53)
    • Minor corrections in Suomi menu language text.(V1.53)
    • Resolves an issue where a hang-up is encountered sometimes after restoring to factory default settings.(V1.53)
    • Resolves the following issues in the Video Store feature: (V1.48)
    o Video Futur Playback.
    o Error in Total Time calculation of the rented video file.

    Kindly download the software at www.philips.com/support
    Forum Mod

  2. #2
    Silver Member
    Points: 2,528, Level: 14
    Level completed: 26%, Points required for next Level: 222
    Overall activity: 12.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Sep 2011
    Location
    Hong Kong
    Posts
    86
    Points
    2,528
    Level
    14
    Thanks
    1
    Thanked 6 Times in 3 Posts
    Rep Power
    3
    thanks

  3. #3
    New Member
    Points: 639, Level: 6
    Level completed: 45%, Points required for next Level: 111
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Mar 2012
    Location
    United Kingdom
    Posts
    3
    Points
    639
    Level
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    1.62 firmware problems

    Hi Remko,

    I upgraded the firmware from v1.56 to v1.62 and the player was almost unusable. It crashed at least 10 times in 15 minutes during playback and menu options. I downgraded the firmware back to 1.56 and it started working again.

    The v1.62 has serious problems which need sorting out as soon as possible. So far this player has been very unreliable requiring restarting at least once or twice during a film.

    Please let me know what can be done about the firmware.

  4. #4
    Gold Member
    Points: 1,784, Level: 11
    Level completed: 78%, Points required for next Level: 66
    Overall activity: 33.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Jul 2011
    Location
    spain
    Posts
    286
    Points
    1,784
    Level
    11
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    Hi I have upgraded this and did not see any problem yet wiht the latest FW. Did you try to reinstall it again to check if it did not wnet wrong the first time you tried?

  5. #5
    Silver Member
    Points: 2,440, Level: 13
    Level completed: 97%, Points required for next Level: 10
    Overall activity: 50.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!
    Stormen's Avatar
    Join Date
    Aug 2011
    Location
    SWE
    Posts
    99
    Points
    2,440
    Level
    13
    Thanks
    6
    Thanked 13 Times in 9 Posts
    Rep Power
    4
    1.61 and 1.62 works fine for me, no problem with crashes.
    No solution to the LFE audiobug though

  6. #6
    New Member
    Points: 639, Level: 6
    Level completed: 45%, Points required for next Level: 111
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Mar 2012
    Location
    United Kingdom
    Posts
    3
    Points
    639
    Level
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Pacman View Post
    Hi I have upgraded this and did not see any problem yet wiht the latest FW. Did you try to reinstall it again to check if it did not wnet wrong the first time you tried?
    I re-installed it twice. Same result. I downgraded to 1.56 and it's working again. This is the most unstable BD player I have ever owned-terrible!

  7. #7
    New Member
    Points: 639, Level: 6
    Level completed: 45%, Points required for next Level: 111
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Mar 2012
    Location
    United Kingdom
    Posts
    3
    Points
    639
    Level
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    have any of you tried playing back any MKV's with firmware 1.62 from a usb source?

  8. #8
    New Member
    Points: 795, Level: 7
    Level completed: 23%, Points required for next Level: 155
    Overall activity: 0%
    Achievements:
    1 year registered500 Experience PointsNew Achievement!

    Join Date
    Dec 2011
    Location
    Italy
    Posts
    6
    Points
    795
    Level
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I'm also experiencing problems when playing files from an USB source, either mkv or mp4, they crash every few minutes. On the whole, it's very annoying. This happens since I installed the new firmware 1.62.
    Before, I only had one firmware (1.61) since it's not much I've bought the player, and these problems never existed.

    Unfortunately I've been careless and when I upgraded the player to 1.62 I deleted the old firmware (1.61) from my pc thinking I wouldn't need it anymore. If I could, now I would perform a downgrade.

    Is there a way to get the firmware 1.61 (italian version, file name is "bdp9600_12_fus_ita")? It's not on the philips site, nor I could find it anywhere.
    Last edited by mayama; 03-19-2012 at 05:36 AM.

  9. #9
    Moderator
    Points: 10,990, Level: 31
    Level completed: 63%, Points required for next Level: 260
    Overall activity: 16.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!10000 Experience Points
    Philips - Remko's Avatar
    Join Date
    Jun 2011
    Posts
    555
    Points
    10,990
    Level
    31
    Thanks
    0
    Thanked 5 Times in 2 Posts
    Rep Power
    10
    Hi,

    We cannot reproduce your issue at our set. Could you help giving us more information on the files played?

    Please send over one of the problem files or post your media info for further investigation.

    Kind regards,
    Forum Mod

  10. #10
    Bronze Member
    Points: 811, Level: 7
    Level completed: 31%, Points required for next Level: 139
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Jan 2012
    Location
    Norway
    Posts
    44
    Points
    811
    Level
    7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I have also experienced big big hangups with my bdp9600 after upgrading to 1.62. biggest problem is the player hanging up when trying to start movies. also have problems with the player being extremly slow to react to the remote control. but the biggest problem is the firmware crashing during install så i had to reinstall 1.61 and when 1.62 was released the install was ok. but the player made me have to restart the player maybe 10 times to play a movie. so i reinstalled the 1.61 firmware. i only wish philips made the old firmware available for everyone, looked all over the place to find the old working firmware.

  11. #11
    Diamond Member
    Points: 51,590, Level: 70
    Level completed: 32%, Points required for next Level: 960
    Overall activity: 57.0%
    Achievements:
    Recommendation Second ClassTagger First ClassOverdrive1000 Experience PointsNew Achievement!
    Awards:
    Posting Award

    Join Date
    Oct 2010
    Posts
    6,039
    Points
    51,590
    Level
    70
    Thanks
    156
    Thanked 174 Times in 155 Posts
    Rep Power
    10
    Hi,

    with which exact movie do you have problems, where you can reproduce the problems?

    Toengel@Alex

  12. #12
    Bronze Member
    Points: 811, Level: 7
    Level completed: 31%, Points required for next Level: 139
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Jan 2012
    Location
    Norway
    Posts
    44
    Points
    811
    Level
    7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    1.62 bugs

    many times it is enough to just try turning on the player. the last movie i tried is "lost in translation" on BD. but the most recurring problem is that the player just hans i have to turn it on and off. i have also had problems trying when choosings the settings menu choice and the icons disappear and it never enters the settings.

  13. #13
    Bronze Member
    Points: 608, Level: 6
    Level completed: 29%, Points required for next Level: 142
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Mar 2012
    Location
    Dordrecht, NL
    Posts
    11
    Points
    608
    Level
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I also have regularly problems with the BDP9600/12 especially just after switching it on.

    The configuration I have is as follows: Philips 46PFL9704H/12 connected to a Onkyo TX-NR906 via HDMI cable (HDMI1 input on TV) to the HDMI main output of the receiver. The receiver is connected via HDMI tot the Philips BDP9600/12. HDMI of the receiver is configured as pass-thru. So the receiver does not/should not process/alter the HDMI data.
    TV is running latest f/w published by Philips. The BDP9600/12 is running f/w rev 1.62.
    Audio on the BDP9600 is set to bitstream. Video output as 1080p24 but I have tried many other options as well.

    Currently HDMI-CEC is off on all 3 devices but is has been on in the past.
    I use the Philips Prestigo SRT8215/10 to manage the 3 sets.

    First of all it takes awfully long before the 9600 is fully operational and has checked if a disc is inside or not. Often after startup is completed I get a HDCP error. Sometimes I get a green image on the tv screen with vertical striping. Sometimes it just functions ok. It is not really predictable. If there is a HDCP error I most of the time have to switch off the receiver and have to cold start the BDP9600 before it functions as you would expect to.
    What also often happens is stuttering image distorted sound (clicks in the sound, etc) or very hard clicks after resuming playing when you have paused. This can almost always be fixed by ejecting the disc and reloading it. Often it looks like the "software" of the movie on the BD was not correctly loaded ejecting and reloading seems to fix this. In the past (less often with 1.61 and 1.62) I also often noticed that for example background music was on normal playing sound level while the voice sound level of the actors was barely noticeable. Ejecting and reloading the disc always fixed this.

    It also often happens that the bootscreen of the BDP9600/12 appears at start up but the icons with settings, Net TV, etc never appear because the player is hung up or whatever....

    Since I have rev 1.61 and now 1.62 it takes much more time to start up reliably and I have to cold start much more than before. I have tried many different sequences of starting up / delays etc but it remains unpredictable if playback will function right away as it should.

    Besides that I have to make the remark that a f/w upgrade via internet doesn't seem to work for the BDP9600/12. I always have to do it via the usb stick. Why is that?

    Same seems to be true for my 37PFL9666H/12 in the bedroom. For that tv it only functioned once.
    For the 46PFL9704H/12 it functioned ok until I installed the version with Joint Space but that was clearly stated by Philips that that version should be installed via usb stick.
    Last edited by Rhino; 03-19-2012 at 09:21 PM.

  14. #14
    Diamond Member
    Points: 51,590, Level: 70
    Level completed: 32%, Points required for next Level: 960
    Overall activity: 57.0%
    Achievements:
    Recommendation Second ClassTagger First ClassOverdrive1000 Experience PointsNew Achievement!
    Awards:
    Posting Award

    Join Date
    Oct 2010
    Posts
    6,039
    Points
    51,590
    Level
    70
    Thanks
    156
    Thanked 174 Times in 155 Posts
    Rep Power
    10
    Hi,

    do your problems also occur if you connect the BDP directly to your TV?

    Toengel@Alex

  15. #15
    Bronze Member
    Points: 608, Level: 6
    Level completed: 29%, Points required for next Level: 142
    Overall activity: 0%
    Achievements:
    3 months registered500 Experience PointsNew Achievement!

    Join Date
    Mar 2012
    Location
    Dordrecht, NL
    Posts
    11
    Points
    608
    Level
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Toengel View Post
    Hi,

    do your problems also occur if you connect the BDP directly to your TV?

    Toengel@Alex
    Hi Toengel,

    No, I did not check that. The whole purpose of having a AV receiver is of course to use it when you watch a film.

    I did however discover that in order for a f/w upgrade to run successfully I need to connect the BDP9600/12 directly to the TV.

    I also realised yesterday evening that it has been a while that I tested the start up sequence by starting with switching the AV receiver on, etc.

    Yesterday evening I tested 3 different sequences:
    1. Start with switching the TV on wait 22,5 secs, than switch on AV receiver, wait 5 secs and choose right input on AV receiver, than switch on BDP9600/12, switch TV sound on Mute, wait 1,5 secs and choose right HDMI input on TV --result after detecting no disc the BDP shows HDCP error, black screen on TV
    2. Start with switching on TV & BDP9600/12, wait 22,5 secs and switch on AV receiver. After 5 secs choose right input on AV receiver, after 5 secs choose mute on TV and after 1,5 secs choose right HDMI input on TV --> HDCP error
    3. Switch on AV receiver, after 1,5 sec choose right HDMI input for BDP. After 5 secs switch on BDP9600/12. Wait until No Disc is detected and display on BDP9600/12 shows Home. Switch on TV. After 22,5 secs choose Mute and after 1,5 secs choose right HDMI input --> no HDCP error and all icons of the BDP9600/12 are shown.

    I am going to test if scenario 3 is a reliable one and not just a 1 shot success.

    Anyway it is my experience that the HDMI protocol is very timing sensitive and as such error prone.
    Also behaviour seems to differ per f/w revison level. Besides that there are simply too much variables/parameters you have to watch for to get things set up correctly.

    In the past I had a 32PFL9830 (HDMI v1.1) in my living room with the same Onkyo TX-NR906 and a Onkyo DV-BDF507. At that time I also regularly had green screens and vertical striping etc. Less than now but they were there. When I replaced the 32PFL9830 by the 46PFL9704H/12 I really had much less problems compared to now.
    But the thing is that when everything is functioning as it should the image & sound quality using the BDP9600/12 is simply much better. The sound is really more 3D like and better defined and the picture quality is also quite a bit better!
    Last edited by Rhino; 03-20-2012 at 11:56 AM.

Page 1 of 2 12 LastLast

Similar Topics

  1. BDP7500MKII Latest Firmware upgrade (1.60) has been released
    By Philips - Remko in forum Blu-ray: BDP7000 Series
    Replies: 59
    Last Post: 08-28-2012, 04:01 PM
  2. MBD3000 Latest Firmware upgrade V1.07 has been released
    By Philips - Remko in forum Blu-ray: General and Others (MBD/PB Series)
    Replies: 7
    Last Post: 02-02-2012, 08:54 PM
  3. BDP9600 Latest Firmware Upgrade (1.61) has been released
    By Philips - Remko in forum Blu-ray: BDP9000 Series
    Replies: 1
    Last Post: 12-26-2011, 11:12 AM
  4. BDP9600 Latest Firmware upgrade (V1.60) has been released
    By Philips - Remko in forum Blu-ray: BDP9000 Series
    Replies: 20
    Last Post: 11-13-2011, 08:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •