After trying to get this connection set up for over 4 hours including 2 hours spent searching these forums, I am ready to admit defeat and seek the collective wisdom for this issue. I appreciate any information you are willing to pass on.

I have a BDP7520/F7 that is updated to Version 1.031. When trying to get it to connect through WiFi Media Connect it states it doesn't find any servers. I have tried installing the upgrade again from a SD card, which appeared successful (no errors, all features appear to work), but this issue remains.

The PC I am connecting is as follows:

Intel i7-2600 @ 3.4Ghz.
8GB Memory
1Gb GDDR5 Video
Windows 7 Home Premium (64-bit)

I have WiFi Media Connect installed and it appears to to be running fine, but it never detects the Blu-Ray player as being on the network. I have uninstalled and reinstalled, defragged, and tried different installation locations. Everytime the software starts and works, but the connection fails.

My last bit of troubleshooting was my network itself. I have a Cisco Wireless N router that is connected to a cable modem and is secured with WPA2 protection. Being as the PC never has issues connecting and the BluRay is only about 2 feet from the router, it too always connects and will stream Netflix, Blockbuster, or Vudu without problems. However, the PC and Blu Ray were still unaware of each other's existance. I tried restarting the router and even removed all protection, making the router a free access WiFi hotspot. Again, both devices connect 100% to the internet, but not to each other.

So, as I stated above, after doing and redoing the above process and bringing on an eye strain headache from reading so many other forum posts on these forums, I concede defeat and seek any words of wisdom that are thrown my way. Thanks.