Hello everybody!

So, as proud as i could be, i recently bought myself a new soundsystem from Philips, obviously.
To my surprise, it has encountered numerous faults. I will describe the errors more thoroughly, but as the system is now the faults are:

Flickering on the UI-Screen
Software lag.
Massive freezing.

This post is pointed out to other consumers with the same problem, and for the support team for help.(sadly i doubt there will be any, seeing that when i called the support center today, they weren't able to help me out, and they were lacking of severe expertise.) Anyway. the problems that i have encountered is, in detail:

Flickering on the UI-Screen, this occurs when the system is playing sound, and when i navigate through the D-Pad physically on the stereo. Not much more to say about it. it seem to me to be a bad connection to the board internally in the device, or it might be the connection on the screen itself.

There is a slight software-lag, nothing much to complain about, but the lag is almost never consistent. Its almost like it could take half a second to respond contra 1 second at the next click, not to be complaining.

When interacting with "Internet Radio" "WIFI Music Streaming(Android based)" "Spotify" the system often completely freezes up. This is actually a dealbreaker for me, when first reviewing the soundsystem in the store, i was astonished, not kidding. But the moment i took it home, it was like prematurely ejaculating, great expectations, embarrassing, but somewhat satisfied.

If you have any tips and tricks on how to fix this, please let me know. And it would be much appreciated if the support team could look this up. And yes, i have reset the device to factory settings, and set it up all over again. it also has the latest firmware. which in my opinion is a little old now. Philips should start renewing their software soon, since this could simply be a software error. I am 2 days in on this new product, and i would really like to get this fixed as soon as possible.

Sincerely TS