Have recently changed router to a Virgin Superhub, since then cannot connect to internet radio and device not found by my PC wadm. I have checked the router settings are on "WPA auto". I saw in some other posts that people recommended using WPA2-PSK (tkip) but this option is not available with my router.

Any other settings I should change or any other suggestions? Want my internet stations back!!

ta!