Results 1 to 8 of 8
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 369, Level: 4
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience PointsNew Achievement!

    Join Date
    Jul 2012
    Location
    Singapore
    Posts
    6
    Points
    369
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    HTS9140/98 Subwoofer no sound

    I recently purchased the sound bar but after 10 days the sub woofer is not working(no sound). Firmware is updated to the latest version. I've been sending emails to Philips but i haven't gotten any replies from them. Any other cases like this?

  2. #2
    Diamond Member
    Points: 4,685, Level: 20
    Level completed: 9%, Points required for next Level: 365
    Overall activity: 25.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!
    Awards:
    Discussion Ender

    Join Date
    Jul 2010
    Posts
    1,083
    Points
    4,685
    Level
    20
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    6
    Quote Originally Posted by Ed Canaya View Post
    I recently purchased the sound bar but after 10 days the sub woofer is not working(no sound). Firmware is updated to the latest version. I've been sending emails to Philips but i haven't gotten any replies from them. Any other cases like this?
    better go to service for a check. potentially there are several reasons and they are not that firmware related.
    1) use it for too long (i dont know how long = too long) that it is burnt
    2) the current is too significant while you turn it on, so it's burnt
    3) there s no audio output passthrough to the subwoofer

    these have to be checked and prescribed by service centre i think
    Last edited by Philips - QK; 07-27-2012 at 04:02 AM.

  3. #3
    New Member
    Points: 369, Level: 4
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience PointsNew Achievement!

    Join Date
    Jul 2012
    Location
    Singapore
    Posts
    6
    Points
    369
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Kwinnie! thanks for the reply. by the way, the sound-bar wasn't used that long cause i can only turn it on after i come back home from work so total usage is very little. maybe point 2 & 3 are possible cause.

  4. #4
    New Member
    Points: 369, Level: 4
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience PointsNew Achievement!

    Join Date
    Jul 2012
    Location
    Singapore
    Posts
    6
    Points
    369
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Just to update, Philips technician confirmed that i have a dead subwoofer. Im still awaiting for the replacement part. Will update you all guys soon.

  5. #5
    New Member
    Points: 369, Level: 4
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience PointsNew Achievement!

    Join Date
    Jul 2012
    Location
    Singapore
    Posts
    6
    Points
    369
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    The subwoofer replacement still didn't solved my issue. Support here is very hard to get. How can i get Philips attention to help me solved this matter???? Been calling them again and again, saying will escalate blah blah blah.. A 10 day product that failed..still remains unresolved..Common Philips...

  6. #6
    Diamond Member
    Points: 4,685, Level: 20
    Level completed: 9%, Points required for next Level: 365
    Overall activity: 25.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!
    Awards:
    Discussion Ender

    Join Date
    Jul 2010
    Posts
    1,083
    Points
    4,685
    Level
    20
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    6
    how can it be? i mean why replacing subwoofer still doesnt solve your issue? ?_?
    it's another dead set?

    how s your case now with SGP consumer care?

  7. #7
    New Member
    Points: 369, Level: 4
    Level completed: 19%, Points required for next Level: 81
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience PointsNew Achievement!

    Join Date
    Jul 2012
    Location
    Singapore
    Posts
    6
    Points
    369
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by kwinnie View Post
    how can it be? i mean why replacing subwoofer still doesnt solve your issue? ?_?
    it's another dead set?

    how s your case now with SGP consumer care?
    Hi Kwinnie,

    According to Philips, there's some board issue with my head unit, so in the end they sent me a new set .

  8. #8
    New Member
    Points: 14, Level: 1
    Level completed: 27%, Points required for next Level: 36
    Overall activity: 0%
    Achievements:
    New Achievement!

    Join Date
    Dec 2012
    Posts
    1
    Points
    14
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Ed, how is your new set?

    The unit I bought also went to no sound after about one month with very light uses. I'm contacting Phillips for a replacement as well.

    I'm wondering whether the problem is just unit-specific or general to all units of this hts9140 model? This would affect our decision on whether we shall ask for return & refund or just exchange it.

    Thanks!

Similar Topics

  1. installing subwoofer to led 4000 series?
    By jslaterdk in forum Smart TV: Installation
    Replies: 6
    Last Post: 06-29-2012, 04:05 AM
  2. HTS8562/12: how is the surround experience / subwoofer
    By Markus77 in forum Sound: Immersive Sound (5.1 system)
    Replies: 2
    Last Post: 05-14-2012, 03:42 PM
  3. BDP2600/98 and BDP9600/98 Infrared Signal Confilct
    By tere_lim in forum Blu-ray: BDP2000 & 3000 Series
    Replies: 1
    Last Post: 05-07-2012, 09:16 PM
  4. HTS5120 Soundbar problem subwoofer and audio bad
    By griverosf in forum Blu-ray: HTS Series
    Replies: 8
    Last Post: 03-03-2012, 03:45 PM
  5. 46PFL8605 + HTS9140 - no sound in TV
    By Lech1 in forum Blu-ray: HTS Series
    Replies: 2
    Last Post: 04-26-2011, 08:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •