Results 1 to 3 of 3
  • Topic Tools
  • Display
  • Bookmark and Share

Hybrid View

  1. #1
    New Member
    Points: 288, Level: 3
    Level completed: 38%, Points required for next Level: 62
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience PointsNew Achievement!

    Join Date
    Aug 2012
    Posts
    2
    Points
    288
    Level
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    BDP7500 MKII stopped working, no picture.

    Hi,

    does anyone have a good idea as to what happened to my BDP7500 MKII device? It is connected to a Philips 42PFL6805H TV via HDMI. While playing back a DVD, it suddenly did not show any picture anymore and the TV was displaying a message that no video signal is present. The problem now persists with any other DVD. The player just shows the short "boot screen" (displaying the Philips Blueray logo on the TV when restarting it) but nothing else. It still reacts to the commands of the remote (e.g. to eject the disc), but I cannot see any menu.

    Things I tried:
    - Unplugging the player from power supply and LAN.
    - Switching the HDMI cable.
    - Pressing HOME, 731 to reset the video.
    - Switching output format by pressing HDMI.
    - Removing the player from the TV's menu and re-adding it.

    Any tips?

    Mark

  2. #2
    Silver Member
    Points: 1,401, Level: 10
    Level completed: 26%, Points required for next Level: 149
    Overall activity: 36.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Nov 2011
    Posts
    242
    Points
    1,401
    Level
    10
    Thanks
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    3
    So you see nothing it all? Does another device work on the HDMI entry that you used? Did you try a different HDMI connection? A different TV?

  3. #3
    New Member
    Points: 288, Level: 3
    Level completed: 38%, Points required for next Level: 62
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience PointsNew Achievement!

    Join Date
    Aug 2012
    Posts
    2
    Points
    288
    Level
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for your reply.

    The HDMI input of the TV (and the cable) works fine, e.g. with an AppleTV.
    The player does show a picture while "booting", but as soon as it's up, there is no picture at all anymore. I suppose it's a case for sending it in for service. I just wanted to make sure that I did not overlook something stupid...

Similar Topics

  1. WAC7500: Bass Stopped Working
    By amikolajczyk in forum Sound: Other Wireless Audio Models
    Replies: 4
    Last Post: 10-30-2012, 01:03 PM
  2. Sound has stopped working
    By cybertalis in forum Sound: Other Wireless Audio Models
    Replies: 1
    Last Post: 08-04-2012, 02:40 PM
  3. BBC iPlayer has stopped working
    By rapidegg in forum Smart TV: News
    Replies: 0
    Last Post: 07-31-2012, 06:53 PM
  4. BDP7500 MKII can't detect disk
    By FranckJ in forum Blu-ray: BDP7000 Series
    Replies: 2
    Last Post: 02-27-2012, 04:52 PM
  5. BDP7500 mkII + The Expandables Blu Ray
    By pigmachine in forum Blu-ray: BDP7000 Series
    Replies: 3
    Last Post: 07-21-2011, 06:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •