Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #16
    New Member
    Points: 12, Level: 1
    Level completed: 23%, Points required for next Level: 38
    Overall activity: 0%
    Achievements:
    New Achievement!

    Join Date
    May 2013
    Posts
    1
    Points
    12
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I too have the same problem. Bought it in february and after the first charge it just wouldn't charge again. Now it only runs when it is connected the AC power. What's the problem here? Can it be fixed?

  2. #17
    New Member
    Points: 1,957, Level: 12
    Level completed: 36%, Points required for next Level: 193
    Overall activity: 9.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Sep 2011
    Location
    Wellington, New Zealand
    Posts
    9
    Points
    1,957
    Level
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Asbak View Post
    I too have the same problem. Bought it in february and after the first charge it just wouldn't charge again. Now it only runs when it is connected the AC power. What's the problem here? Can it be fixed?
    Yes it can be fixed by changing the onboard battery but your local service centre will have to do it. Mine is now working but I still wasn't happy about having a week old unit taken and refurbished but every new one I've had has this problem, shocking build quality

  3. #18
    Silver Member
    Points: 1,246, Level: 9
    Level completed: 48%, Points required for next Level: 104
    Overall activity: 0%
    Achievements:
    New Achievement!1000 Experience Points1 year registered

    Join Date
    Feb 2013
    Posts
    198
    Points
    1,246
    Level
    9
    Thanks
    2
    Thanked 8 Times in 8 Posts
    Rep Power
    2
    hi asbak,

    langers1972 is correct. unfortunately, you have to contact your local Philips service centre and they will be able to fix it for you.

    @langers1972 - that's very unfortunate, hope the last unit will work forever!

  4. #19
    New Member
    Points: 1,957, Level: 12
    Level completed: 36%, Points required for next Level: 193
    Overall activity: 9.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!

    Join Date
    Sep 2011
    Location
    Wellington, New Zealand
    Posts
    9
    Points
    1,957
    Level
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I don't believe it, the replacement one has now died too, at least they're consistent in so far as they're all RUBBISH

Page 2 of 2 FirstFirst 12

Similar Topics

  1. Fidelio DS8550 seems to turn itself on
    By langers1972 in forum Sound: DS8000- and DS9000-series
    Replies: 14
    Last Post: 06-26-2012, 08:30 AM
  2. DS8550 has the same problem
    By benyapapa in forum Sound: DS8000- and DS9000-series
    Replies: 3
    Last Post: 02-27-2012, 08:17 AM
  3. problem PTA 516 4 PHILIPS 469706
    By xanto in forum TV: 3D
    Replies: 2
    Last Post: 01-25-2012, 05:40 PM
  4. ds8550 instant pairing
    By gkatz in forum Sound: DS8000- and DS9000-series
    Replies: 3
    Last Post: 11-16-2011, 10:57 AM
  5. Philips Wi-fi Mediaconnect big problem
    By Cruzeros in forum TV: Streaming & Network
    Replies: 1
    Last Post: 08-08-2011, 05:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •