Results 1 to 10 of 10
  • Topic Tools
  • Display
  • Bookmark and Share

Hybrid View

  1. #1
    New Member
    Points: 378, Level: 4
    Level completed: 28%, Points required for next Level: 72
    Overall activity: 0%
    Achievements:
    OverdriveNew Achievement!3 months registered250 Experience Points

    Join Date
    Nov 2012
    Location
    Hardenberg Nederland
    Posts
    6
    Points
    378
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Mediaserver in Linux

    I'm in the middle of leaving Windows 8 (a disaster) and installing LinuxMint on my pc.
    In Windows I used a mediaserver. With that I could see on my Philips TV al Photo's and Video's which were on mij PC ( The TV is connected to my homenetwork)
    Now I'm trying to realize the same on LinuxMint. But how?
    I installed MediaTomb. Now on my Philips TV I see: MediaTomb|PC directory. When I choose the last one " Nothing found " is said.
    Starting MediaTomb on my Linux-pc goes to Firefox and gives the message MediaTomb UI is disabled. Check your configuration.

    I'm new on linux. What I'm doing wrong? Does the name PC-directory (a Windows name) mean that I have to do something with Wine?
    Or is there another mediaserver to work with?
    Hope someone gives me a solution; thanks in advance.

    Bart

  2. #2
    Silver Member
    Points: 1,640, Level: 11
    Level completed: 30%, Points required for next Level: 210
    Overall activity: 0%
    Achievements:
    1 year registered1 year registeredTagger Second Class1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Posts
    59
    Points
    1,640
    Level
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3
    I found this video quite helpful configuring MediaTomb. http://www.youtube.com/watch?v=qic11JxRbN8
    At around 2min30 it shows you how to do it

    PC Directory should be there even on Linux

    If you find MediaTomb too complicated there is also PS3 Media Server which is a good open source DLNA UPnP server too.
    http://www.ps3mediaserver.org/ [you don't have to have a PS3 to use it, thats was just the origin of the project ]

  3. #3
    New Member
    Points: 378, Level: 4
    Level completed: 28%, Points required for next Level: 72
    Overall activity: 0%
    Achievements:
    OverdriveNew Achievement!3 months registered250 Experience Points

    Join Date
    Nov 2012
    Location
    Hardenberg Nederland
    Posts
    6
    Points
    378
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks Mike TV,

    I've seen the Youtube demo. And it looks to be nice.....
    But when I start Mediatomb, it still give the message "MediaTomb UI is disabled. Check your configuration."
    And as I said, I'm a newbie in Linux, So I don't know how to solve this. Who helps?

    Bart

  4. #4
    Silver Member
    Points: 1,640, Level: 11
    Level completed: 30%, Points required for next Level: 210
    Overall activity: 0%
    Achievements:
    1 year registered1 year registeredTagger Second Class1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Posts
    59
    Points
    1,640
    Level
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3
    Sounds like there may be something wrong with your MediaTomb installation? I'm not actually Linux user myself.

    Not sure if this is any help [from Ubuntu]
    https://help.ubuntu.com/community/MediaTomb

    Perhaps double check you've installed the correct version of MediaTomb?

    Or post your question on the MediaTomb forum on Sourceforge
    http://sourceforge.net/projects/medi...s/forum/440751

    Or you could also try asking on Ubuntu's forum
    http://ubuntuforums.org/


    Or give MediaTomb a miss and try PS3 Media Server or another Open Source server app. MediaTomb is a bit tricky to set up.

    Edit: Sorry. I've just seen you found MediaTomb forum already.

  5. #5
    Silver Member
    Points: 1,640, Level: 11
    Level completed: 30%, Points required for next Level: 210
    Overall activity: 0%
    Achievements:
    1 year registered1 year registeredTagger Second Class1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Posts
    59
    Points
    1,640
    Level
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3
    That Ubuntu link has your answer

    You need to edit MediaTomb's config.xml to enable the the UI. The config.xml is a text file located at /etc/mediatomb/config.xml.
    They give a couple of examples of how to do it. One uses nano which is a bit technical.
    The others are comand line ways of getting a GUI text editor to open the config.xml
    If your text editor is gedit you could try using the Ubuntu command. [I think your on mint]
    Code:
     gksudo gedit /etc/mediatomb/config.xml
    Once the config.xml is opened in your text editor "uncomment" the XML code by remove the "<!--" and "-->" from before and after the UI line of code.

  6. #6
    New Member
    Points: 378, Level: 4
    Level completed: 28%, Points required for next Level: 72
    Overall activity: 0%
    Achievements:
    OverdriveNew Achievement!3 months registered250 Experience Points

    Join Date
    Nov 2012
    Location
    Hardenberg Nederland
    Posts
    6
    Points
    378
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hello Mike TV

    Thanks for your help

    Enclosed, you will find the config file (renamed). Please would you be so kind and look at it? As far as I can see, there is no such XML-code in it.

    Sorry for my English; thanks in advance
    Attached Files Attached Files

  7. #7
    Silver Member
    Points: 1,640, Level: 11
    Level completed: 30%, Points required for next Level: 210
    Overall activity: 0%
    Achievements:
    1 year registered1 year registeredTagger Second Class1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Posts
    59
    Points
    1,640
    Level
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3
    Sorry, my mistake
    The line you want isn't commented. It is set to "no". You want to change it to yes The lines in question start six down
    Code:
    <server>
        <ui enabled="no" show-tooltips="yes">
          <accounts enabled="no" session-timeout="30">
            <account user="mediatomb" password="mediatomb"/>
          </accounts>
        </ui>
    Where it says <ui enabled="no" show-tooltips="yes"> change the no to yes.

  8. #8
    Silver Member
    Points: 1,640, Level: 11
    Level completed: 30%, Points required for next Level: 210
    Overall activity: 0%
    Achievements:
    1 year registered1 year registeredTagger Second Class1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Posts
    59
    Points
    1,640
    Level
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3
    Just a heads up: Linux/Unix system files use a special permission. [I'm guessing you speak German? so this is some info on Unix file permissions https://de.wikipedia.org/wiki/Unix-Dateirechte ]

    But its important that you edit the config.xml in the right way so that that the system permission is preserved. That command line way of launching the GUI text editor sets it up so that it will edit the file with the right permission.

    Were you able to launch the text editor using the Ubuntu command?

  9. #9
    Silver Member
    Points: 1,640, Level: 11
    Level completed: 30%, Points required for next Level: 210
    Overall activity: 0%
    Achievements:
    1 year registered1 year registeredTagger Second Class1000 Experience PointsNew Achievement!

    Join Date
    Apr 2011
    Posts
    59
    Points
    1,640
    Level
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    3
    Once you enable the UI you'll have to re-launch MediaTomb for the change to take effect. Then type this url into your web browser http://localhost:49152

    That will take you to the web interface. Take a look at that YouTube video for more on how to configure MediaTomb with your media via the web interface.

    Sorry for thinking you spoke German, I only saw Hardenberg [which looks German to me!]. I just spotted you're actualy in Holland. Can't find a Dutch wikipedia article on Unix File permissions. Sorry.
    Last edited by mike tv; 11-17-2012 at 07:51 PM.

  10. #10
    New Member
    Points: 378, Level: 4
    Level completed: 28%, Points required for next Level: 72
    Overall activity: 0%
    Achievements:
    OverdriveNew Achievement!3 months registered250 Experience Points

    Join Date
    Nov 2012
    Location
    Hardenberg Nederland
    Posts
    6
    Points
    378
    Level
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hello Mike,

    I've done what you said and............ IT WORKS !!!

    Thanks voor your patience. Now I can sit down this Sunday, and look to all my foto's and video's


    Bart

Similar Topics

  1. MEDIASERVER 7 License Key?
    By eitanhu in forum TV: Streaming & Network
    Replies: 10
    Last Post: 02-22-2013, 07:33 AM
  2. Replies: 6
    Last Post: 08-09-2012, 07:23 PM
  3. No connection to mediaserver after update
    By Zzorro in forum Sound: Streamium NP Series (NP3900|NP3700|NP3500|NP3300|NP2900)
    Replies: 50
    Last Post: 01-19-2012, 03:42 PM
  4. 42PFL7606k/02 not connected via mediaserver
    By magician123 in forum TV: Streaming & Network
    Replies: 7
    Last Post: 12-14-2011, 07:23 AM
  5. NP3900 - Mediaserver not found....
    By ft103 in forum Sound: Streamium NP Series (NP3900|NP3700|NP3500|NP3300|NP2900)
    Replies: 7
    Last Post: 10-17-2011, 06:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •