Results 1 to 7 of 7
  • Topic Tools
  • Display
  • Bookmark and Share

Hybrid View

  1. #1
    New Member
    Points: 106, Level: 1
    Level completed: 56%, Points required for next Level: 44
    Overall activity: 0%
    Achievements:
    7 days registered100 Experience PointsNew Achievement!

    Join Date
    Nov 2012
    Posts
    5
    Points
    106
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    BluRay "The Raid" from AFilm doesn't want to play in my BDP7500SL

    Yesterday I tried to play my new BluRay disk "The Raid" from AFilm (Dutch publishing company) in my BDP7500SL.
    After about a minute of disk loading the three icon menu (Disk, USB and Settings) appeared and the front display on the player showed the text "Unknown".

    Trying to play the disk again using the "Disk" icon gave me a warning text overlay in the screen stating "This disc is unknown".

    I've tried playing another disk and that worked fine, so it seems to be an issue with the disk/player combination or the disk itself.

    Since I'm already running the latest published firmware (1.12 from August 2011) I couldn't solve this issue by updating the firmware.

    Can anybody help me with this issue?

    I've also informed AFilm about this, but haven't heard back from them.

    With kind regards,

    Pieter-Jan Kuyten

    --- UPDATE ---

    I still haven't heard back from AFilm (talk about bad customer support). I did post my problems on DVD.nl where someone suggested that my player might be broken. After doing some checks (mainly involving trying to play other BD25 disks from from the same publisher and others that have been known to indicate a broken player) I came to the conclusion that the player hardware isn't broken. So this seems to indicate either a faulty disk (I'll try to get a replacement next Saturday) or a change in the DRM code used on the disk which is incompatible with the latest firmware for the BDP7500SL.

    Does anybody else have this BluRay and is able to play it in their player?
    Last edited by PJK; 11-21-2012 at 07:26 AM. Reason: Updating information

  2. #2
    Platinum Member
    Points: 2,996, Level: 15
    Level completed: 82%, Points required for next Level: 54
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsOverdriveNew Achievement!
    Oscar's Avatar
    Join Date
    Feb 2011
    Posts
    722
    Points
    2,996
    Level
    15
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    4
    Hi PJK,

    The message unknown disc is normally related to a loader issue.

    Only this movie you say and no others?

  3. #3
    New Member
    Points: 106, Level: 1
    Level completed: 56%, Points required for next Level: 44
    Overall activity: 0%
    Achievements:
    7 days registered100 Experience PointsNew Achievement!

    Join Date
    Nov 2012
    Posts
    5
    Points
    106
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yes, this is the first and up till now the only disk I had this problem with. Of course I've only done a small check on suggested titles by the guys on the DVD.nl forum, but uptil now all my BluRay disks have worked without issues and I have a sizeable collection of BluRays.

  4. #4
    Diamond Member
    Points: 4,685, Level: 20
    Level completed: 9%, Points required for next Level: 365
    Overall activity: 25.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!
    Awards:
    Discussion Ender

    Join Date
    Jul 2010
    Posts
    1,083
    Points
    4,685
    Level
    20
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    6
    do you have the EAN of your disc?

    Like what Oscar said, unknown disc issue is usually a loader issue, esp when this error appears for most of the disc.
    In this forum, there are cases that the user only have one disc that shows this error, yet by going to service and exchange the loader it resolves the issue.

    and your warranty over yet for BDP7500SL?

  5. #5
    New Member
    Points: 106, Level: 1
    Level completed: 56%, Points required for next Level: 44
    Overall activity: 0%
    Achievements:
    7 days registered100 Experience PointsNew Achievement!

    Join Date
    Nov 2012
    Posts
    5
    Points
    106
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    If by EAN you mean the same thing as the UPC, then this is the UPC => 8-716777-942345

    I bought my player in late 2009 i.i.r.c. so I think the warranty period is over.

  6. #6
    Diamond Member
    Points: 4,685, Level: 20
    Level completed: 9%, Points required for next Level: 365
    Overall activity: 25.0%
    Achievements:
    1 year registered1000 Experience PointsNew Achievement!
    Awards:
    Discussion Ender

    Join Date
    Jul 2010
    Posts
    1,083
    Points
    4,685
    Level
    20
    Thanks
    0
    Thanked 1 Time in 1 Post
    Rep Power
    6
    hi PJK,

    just search a bit, you can try unplug the HDMI and plug that in again.
    some other users found it works... you can hv a try.

    as for your disc seems no other users in the forum reported the same disc. btw, EAN means the barcode number of the disc.

  7. #7
    New Member
    Points: 106, Level: 1
    Level completed: 56%, Points required for next Level: 44
    Overall activity: 0%
    Achievements:
    7 days registered100 Experience PointsNew Achievement!

    Join Date
    Nov 2012
    Posts
    5
    Points
    106
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks, I'll have a look through the forum and see what pops up and I'll try the HDMI tip.

    In DVDProfiler they call these UPC's (Universal Product Codes), but I see that EAN is the European equivalent => http://www.ehow.com/facts_7148158_ea...tand-for_.html

Similar Topics

  1. BUG: "Back" doesn't work at IP-EPG
    By bta in forum Smart TV: IP-EPG Program Guide
    Replies: 60
    Last Post: 01-05-2013, 03:14 PM
  2. Youtube doesn't react on "Enter" key
    By dimmeagle in forum Smart TV: YouTube
    Replies: 0
    Last Post: 05-12-2012, 12:23 PM
  3. NP1100/12 says "Tracks failed to play. Playback Error"
    By ProToolsKaiser in forum Sound: Other Wireless Audio Models
    Replies: 5
    Last Post: 02-26-2012, 04:02 PM
  4. bluray "Harry Potter and the deathly hallows - part 2"
    By maumau in forum Blu-ray: BDP8000 Series
    Replies: 7
    Last Post: 12-09-2011, 07:43 AM
  5. Philips Bluray 2700/12 "Video Resolution Not Supported"
    By chillock in forum Blu-ray: BDP2000 & 3000 Series
    Replies: 1
    Last Post: 10-25-2011, 02:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •