Rencently my ipod is not supported by one of my 2 ds1100/12 (ipod version 4.2.1). One ds1100/12 is working normally, the other shows a message that the ipod is not supported, it does not display the time (--:--), but it does play music over the speakers. Do I need new firmware for the ds1100/12?