Results 1 to 3 of 3
  • Topic Tools
  • Display
  • Bookmark and Share
  1. #1
    New Member
    Points: 49, Level: 1
    Level completed: 98%, Points required for next Level: 1
    Overall activity: 10.0%
    Achievements:
    New Achievement!

    Join Date
    Jan 2013
    Location
    UK
    Posts
    2
    Points
    49
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    HTS5560 player fault

    I have had my HTS5560 for two years and with little use it has performed perfectly. I have recently had a problem with the blue ray player which plays blueray discs intermittently and refuses to play DVD's at all.
    I am therefore unable to play my blueray and DVD library at all, although I do use the Dolby system with my Humax box.

    I have cleaned the lens with a disc cleaner with no success. Any ideas anyone? 2 years seems a short time for a player fault to develop, I usually expect my pc player/recorders to last the lifetime of the pc - 6 years+.
    Thanks'
    Brian

  2. #2
    Platinum Member
    Points: 2,996, Level: 15
    Level completed: 82%, Points required for next Level: 54
    Overall activity: 0%
    Achievements:
    1 year registered1000 Experience PointsOverdriveNew Achievement!
    Oscar's Avatar
    Join Date
    Feb 2011
    Posts
    722
    Points
    2,996
    Level
    15
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    4
    Hi Brian, some things you might try is to make sure latest firmware is installed. If so reset ot factory settings and reinstall and also might be worth to unplugg and plugg back again.... If all does not help then it looks defective

  3. #3
    New Member
    Points: 49, Level: 1
    Level completed: 98%, Points required for next Level: 1
    Overall activity: 10.0%
    Achievements:
    New Achievement!

    Join Date
    Jan 2013
    Location
    UK
    Posts
    2
    Points
    49
    Level
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by Oscar View Post
    Hi Brian, some things you might try is to make sure latest firmware is installed. If so reset ot factory settings and reinstall and also might be worth to unplugg and plugg back again.... If all does not help then it looks defective
    Thanks for your prompt reply, Oscar. The unplugging worked. I don't know why I didn't think of that.
    Thanks again.
    Brian

Similar Topics

  1. HTS5560/12 Unknown Disc
    By Zanzan in forum Blu-ray: HTS Series
    Replies: 1
    Last Post: 12-25-2012, 06:51 PM
  2. HTS5560/12 usb port power problem
    By mad4hit in forum Sound: Immersive Sound (5.1 system)
    Replies: 0
    Last Post: 12-10-2012, 11:12 AM
  3. hts5560 - volume adjustment problem
    By arcidae2000 in forum Sound: Immersive Sound (5.1 system)
    Replies: 5
    Last Post: 10-26-2012, 01:31 PM
  4. AE50101/05 DAB Radio Fault
    By Goldfish in forum Sound: Other Models
    Replies: 0
    Last Post: 09-01-2012, 08:27 AM
  5. My HTS5560/12 doesn't recognise de latest 3D bleu-ray movies.
    By jacques1234 in forum Blu-ray: HTS Series
    Replies: 4
    Last Post: 07-25-2012, 10:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •